WordPress.org

Ready to get started?Download WordPress

Forums

WP Super Cache
[resolved] How to stop the plugin caching the online contact form? (7 posts)

  1. Marekant
    Member
    Posted 1 year ago #

    I'm using the karma wordpress theme and the online contact form is sending an error "Are you sure you want to do this?" the guys at Karma have checked and advise to set up Wp super cache not to cache the contct form by entering the contact form url on the Wp super cache settings page somewhere that say "do not cache url containing..", but.. I can't find this option?

    There is a section that says..

    Do not cache the following page types. and that is where I get lost
    What type is the contact form?

    Any advice will be much appreciated
    Marek

    http://wordpress.org/extend/plugins/wp-super-cache/

  2. esmi
    Forum Moderator
    Posted 1 year ago #

    What happens if you use the default Twenty Twelve theme?

  3. Marekant
    Member
    Posted 1 year ago #

    The contact form is part of the Karma theme so I don't understand why testing the default twenty twelve theme will help?

    ( I cannot imagine switching my client's website theme )

  4. esmi
    Forum Moderator
    Posted 1 year ago #

    In that case, I can only suggest that go back to the theme's vendors. From the sounds of it, there is an issue in that theme.

  5. Marekant
    Member
    Posted 1 year ago #

    Here is their full explanation which I hope will show that there is hopefully a simple getaround, the only problem being that I lack the knowledge to apply the fix...

    You are encountering this issue because you had installed a cache plugin called wp super cache and it is caching the contact form.
    You need to set wp super cache not to cache the contact form, you can do this by entering the contact form url in wp super cache setting page.. somewhere that says do not cache url containing…

    In the webpage html source code of the contact form, there is a hidden field called _wpnonce for security check.
    1

    <input type="hidden" id="_wpnonce" name="_wpnonce" value="5acb700fe6" /><input type="hidden" name="_wp_http_referer" value="/contact" />

    When you post the form, the contact form code will check and verify this _wpnonce value and the http referer, so as to make sure that it is data submit from your webpage and not any other mail spamming program.
    If the _wpnonce value is different, it will show you the error message “Are you sure you want to do this?” and terminates the program immediately after.

    This is what you actually encountered…
    When you submit the form and coincidentally wp super cache regenerates a new cache file, the _wpnonce value posted will be different from the verification value.
    This will trigger the WordPress error message.. which is .. “Are you sure you want to do this?”
    wp super cache only regenerates the cache file after certain period of time, this explains why you encounter this issue randomly.

    So, can I set up WP Super cache not to cache the contact form url, and how do I do that?

    Thanks Marek

    [No bumping. If it's that urgent, consider hiring someone.]

  6. Marekant
    Member
    Posted 12 months ago #

    I am not sure if the above comment about 'No Bumping' from 3 days ago means that I will not now be answered? In an effort to clarify, my last post was to modify and simplify my query and was in no way intended to 'bump' the original.

  7. Marekant
    Member
    Posted 11 months ago #

    I am delighted to report that my query has been resolved by firstly reading the very helpful article "Recommended WP Super Cache Settings for Beginners" written just a few days ago by Bhagwad Park on http://www.webhostinghero.com/recommended-settings-for-wp-super-cache-beginners

    Secondly Bhagwad kindly explained exactly where within the settings, I should apply the very simple piece of code to instruct WP Super Cache not to cache the contact page on my site. If others have a similar problem, this is where you place your code...

    Under the “Advanced” tab in WP Super Cache settings, scroll down till you see the “Accepted Filenames & Rejected URIs” heading. The second item should be a textbox with two lines of code already filled in. In the third line, type in /contact . ( or the url you wish to stop being cached ) That should prevent WP Super Cache from caching the page. ie.

    wp-.*\.php
    index\.php
    /contact

    and then click save...

    You can then check in your source code to see if the page is being cached or not, by looking to see if there is a message at the foot of the source code page from WP Super Cache saying "This page has been cached"

    Hope this helps others!

    Regards
    Marek

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic