WordPress.org

Ready to get started?Download WordPress

Forums

How to Stop 301 Redirects And Remove a Dead Diamond Post (6 posts)

  1. paulgian
    Member
    Posted 1 year ago #

    Hi,

    Google Webmaster tools is giving me a message in HTML improvements that I have duplicate tags/descriptions on 2 of my pages.

    The issue started when I created a post with the wrong url permalink.

    the-perfect-1-5-carats-diamond-for-a-loved-on

    If you click the link now, it redirects to this http://onlinediamondbuyingguide.com/blog/recommendations/2012/12/the-perfect-1-5-carats-diamond-for-a-loved-one/

    There was a missing letter at the end and I corrected it by adding an "e" to the end of the string. A few weeks down the road, Google is telling me that i have duplicated text. I tried logging on via ftp to search and delete the old created file "the-perfect-1-5-carats-diamond-for-a-loved-on" but couldn't find it in my ftp server.

    Is it residing somewhere else and how do I get rid of the old file instead of having it automatically redirected and causing issues in webmaster tools?

    Thanks alot!

  2. Jesús Franco
    Member
    Posted 1 year ago #

    Looks like you are using a redirection plugin, I curled your linked URL and it returns a 200 code (that's fine), then removed the last 'e' and it returns a 301 code (permanent) redirection to your linked URL (the one with loved-one/ at the end).

  3. paulgian
    Member
    Posted 1 year ago #

    ok. i seemed to have identified the issue and traced it back to the plugin - Platinum SEO. Even after i uncheck the box for "Automatically do 301 redirects for permalink changes:", the redirection still persists.

    Would you have any idea on how to go about overwriting or deleting the redirection?

    Thanks alot

  4. Jesús Franco
    Member
    Posted 1 year ago #

    No idea, probably you could have better luck in support forum of the plugin, try searching previous posts there.

  5. lolcaption
    Member
    Posted 1 year ago #

    From the above post it looks like everything's fine. Perhaps Google just hasn't picked up the redirection yet.

    You could check your .htaccess file as Platinum SEO likely created a rule there. You could delete that rule but then if you do any search engines or inbound links to your new URL (......diamond-for-a-loved-one/) will then fail. And I'd say that 404 would be worse than a duplicate content warning.

    Alternatively, you could change the redirect to go the other way and redirect ".....diamond-for-a-loved-one/" --> ".....diamond-for-a-loved-on/" that should cover both scenarios.

  6. Jesús Franco
    Member
    Posted 1 year ago #

    @lolcaption that looks like a way to looping a redirection forever.

Topic Closed

This topic has been closed to new replies.

About this Topic