WordPress.org

Ready to get started?Download WordPress

Forums

Pinboard
[resolved] how to show posts preview on home page (8 posts)

  1. sundas
    Member
    Posted 1 year ago #

    The pinboard theme has the feature of showing post preview on home page with a picture, i have searched everywhere there are no instructions on how to do that, i am a newbie in wordpress and this maybe very simple but i cant fiure out how its done. Please guide me, any help would be really appreciated

    and after the posts show on the home page is it possible to link them to a wordpress page?

    Thanks

  2. paul.a.cunn
    Member
    Posted 1 year ago #

    Lets get your first question answered before we go further. To make the posts show up on the homepage go to "Appearance" then "Customize" on your current theme. Then on the right you will see the item "Static Front Page" Make sure that this option is "Most recent posts" Then create some posts. In each post add a "Featured Image" This should be an option on the right below where you actually type the content. Here is a screen shot, you can see the featured image on the right.

    http://snag.gy/LQqVN.jpg

    Once you add these posts they should now show up on your home page.

    Cheers!

  3. sundas
    Member
    Posted 1 year ago #

    I did that, and the posts do start showing but they dont show on the default homepage,instead they show on a page which appears when i click on the logo and i cant find that page, its most likely the index.php page since it doesnt have any further extension after the domain where wordpress is installed and i have no clue how to edit that from wordpress dashboard.

    Also the page is not full width, please take a look and tell me what i'm doing wrong.

    this is the pages that shows posts http://www.riseleadershipgroup.com/wptest19_2/

    and this is my homepage
    http://www.riseleadershipgroup.com/wptest19_2/home/

    Thanks

  4. paul.a.cunn
    Member
    Posted 1 year ago #

    OK so I think you have a couple issues which will involve a little css but not bad. First make sure you have your landing page set as what it should be. Go to "Settings" then "Reading" Make sure that your front page displays your latest post, save the settings. Then go to "Appearance" then "Menus" and expand the "Home" menu option. Change the url in this option to be http://www.riseleadershipgroup.com/wptest19_2/ instead of the /home page. Now you need to add the following custom css so that your landing page is 1140px wide.

    .page-template-template-no-sidebars-php #wrapper,
    .page-template-template-blog-no-sidebars-php #wrapper,
    .page-template-template-portfolio-no-sidebars-php #wrapper {
    max-width:1140px;
    }

    This should do everything you want,

    Cheers!

  5. sundas
    Member
    Posted 1 year ago #

    OMG!! thankyou so much that resolved my issue,i had been googling all over for this!..

    there is one more thing, the posts i marked sticky for the slider are also showing up in the page post preview in content area, how can i fix that?

  6. sundas
    Member
    Posted 1 year ago #

    should i start a new thred for the latest issue and mark this resolved?

  7. paul.a.cunn
    Member
    Posted 1 year ago #

    You should always start a new thred for the latest issue, but w/e. In order to hide the Slider posts from the main loop what I did was make a category called "Slider Posts" Then I updated all my slider posts to be in only this category. I then went to "Appearance" then "Theme Options" under "Portfolio Page" I picked "Slider Posts" for my portfolio category. Then under "Home Page" I check the "Exclude Portfolio Category from Main Loop" This should do the trick.

  8. sundas
    Member
    Posted 1 year ago #

    Thank you soo very much, this solves everything. You've been really helpful aand patiently explained everything thanks again :D

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic