WordPress.org

Ready to get started?Download WordPress

Forums

how to set 'uploads' to permission 777 (9 posts)

  1. ditkannietwaarzijn
    Member
    Posted 7 years ago #

    i read in a lot of topics that i need to set my permissions for the uploads directory to 777. but i don't know how to set this permission to 777. what do i have to to achieve this?
    and then it should be possible to upload with wordpress?

  2. Michael Bishop

    Posted 7 years ago #

    Changing_File_Permissions

    Let us know if you have any questions after reading that

  3. ditkannietwaarzijn
    Member
    Posted 7 years ago #

    it still says: the document could not be moved. i set the settings of 'uploads'to 777 but appearantly it didn't work or there is another problem.

  4. Michael Bishop

    Posted 7 years ago #

    What are the permissions for your wp-contents folder?

  5. caNative
    Member
    Posted 7 years ago #

    i tried that one already :-(

  6. sobeita
    Member
    Posted 7 years ago #

    777, like you know, is the permission setting which allows any anonymous user to read, write, and execute code on your server. The setting is extremely vulnerable, and bots constantly search for folder names that commonly have this setting. A download such as WordPress's will almost definitely name the folders identically, making it easy for a bot to find the folder and expose it for a compromise.
    br
    I was wondering about this myself: is it necessary to change your settings to 777 in the given folders? Please respond.

  7. Doodlebee
    Member
    Posted 7 years ago #

    You should change your "uploads" folder to 777 just long enough to do so, log into your admin panel and upload an image through the uploading tool. Then change the permissions on that folder back to default (should be 755). WordPress only needs the one instance to connect to the folder to get permission - once it has it, it always has it.

  8. marketanomaly
    Member
    Posted 7 years ago #

    I changed my settings to 777, uploaded a file, then switch the permission back to 755. I still get the error

    The uploaded file could not be moved to /home/tadias/public_html/wp-content/uploads/2007/05

    Any other ideas on what causes this? Could there be a problem with how I have define my user group on the server? Thanks for your help.

  9. pramodd
    Member
    Posted 7 years ago #

    Both wp-content and uploads folder should have 777 permissions.

Topic Closed

This topic has been closed to new replies.

About this Topic