WordPress.org

Ready to get started?Download WordPress

Forums

WordPress File Monitor Plus
How to set the file check root? (5 posts)

  1. sky captain
    Member
    Posted 5 months ago #

    I'm unclear on how to set the file check root. When I use the default and do a manual scan, I get this result:

    Warning: filesize() [function.filesize]: stat failed for /home/content/93/7927593/html/stats/logs in /home/content/93/7927593/html/wp-content/plugins/wordpress-file-monitor-plus/classes/wpfmp.class.php on line 290
    
    Warning: filemtime() [function.filemtime]: stat failed for /home/content/93/7927593/html/stats/logs in /home/content/93/7927593/html/wp-content/plugins/wordpress-file-monitor-plus/classes/wpfmp.class.php on line 293
    
    Warning: md5_file(/home/content/93/7927593/html/stats/logs) [function.md5-file]: failed to open stream: No such file or directory in /home/content/93/7927593/html/wp-content/plugins/wordpress-file-monitor-plus/classes/wpfmp.class.php on line 296

    And then when I changed the file check root to just "/" (the root of my website?) I got a whole page of errors.

    http://wordpress.org/plugins/wordpress-file-monitor-plus/

  2. Kimberly
    Member
    Posted 5 months ago #

    chmod the permission

  3. sky captain
    Member
    Posted 5 months ago #

    The permission for the root of my whole website? That sounds dangerous.

  4. Kimberly
    Member
    Posted 5 months ago #

    Oh no no i mean you may need to modify the permission for the directory itself or maybe "logs" is a file based on what the errors are saying. It seems your /logs may need to update its permissions to the wordpress preferred defaults of 755 (for directories) or if its a file then 644.

    But as a heads up the check root should be set to your home directory (where your wordpress is located). For example lets say ive installed wordpress site at: /home/kimberly (so that means my /wp-content would located at /home/kimberly/wp-conent). Then i would set this plugin's check root field to be: /home/kimberly.

    Maybe the best solution is to just have this plugin ignore that file/directory entirely by adding it to your exclusion list.

    Let me know how things go. I am intrigued by your problem

  5. andrewmills
    Member
    Posted 5 months ago #

    Just going to second what Kimberly said. "/" is unlikely to be the root of your website, and you probably need to fine tune the setting for the "File Check Root" a little bit.

    For example, it might be something like:

    /home/SkyCaptain/public_html

    (Note: This examples pretends/assumes SkyCaptain is your web hosting account name. Substitute that part accordingly.)

    I'd be very surprised if the logs folder was inside your public_html folder, so this change should resolve that issue as well. If I'm mistaken, then definitely exclude them because they are going to give you constant alerts.

Reply

You must log in to post.

About this Plugin

About this Topic

Tags

No tags yet.