WordPress.org

Ready to get started?Download WordPress

Forums

How to set Image Linked to File by default? (8 posts)

  1. s0what
    Member
    Posted 4 years ago #

    Maybe I am wrong, but in older wp versions there was an option where I could set default Link URL of Image. Can't find it anymore on 2.9.2

  2. s0what
    Member
    Posted 4 years ago #

    this is one very easy question. please answer :)

  3. Inspired2Write
    Member
    Posted 4 years ago #

    Is there a reason why you want the image linked? It isn't necessary to have it linked, if it's not needed. Where it says 'Link URL' you have the option to not even link it, if you wish.

    If you want to link it, and if you've already closed out the box, from your editor, click on the image and then select the 'edit' option at the top left of the image. Then under 'Edit Image' go down to where it says, "Link URL" and then select the button which says, "Link to Image". It will automatically link the image for you.

  4. s0what
    Member
    Posted 4 years ago #

    thanks for replay.
    My blog contains lots of users and they are writing posts with images. 99% of images are clickable and open with Highslide.
    Every time user is inserting image, he has to click to "File URL", because default option is "Post URL".
    And what I want is to make default "File URL", so user doesn't has to click there anymore.

  5. esmi
    Theme Diva & Forum Moderator
    Posted 4 years ago #

    The current url type is dependant upon the last url option used. So if it keeps reverting from File Url to Post Url, it's because one of your users is choosing Post Url.

  6. s0what
    Member
    Posted 4 years ago #

    thanks for good replay, esmi, but that doesn't work for me anymore.
    2.9.2 sets "attachment" by default no matter what has been set previous time :(

  7. andyhoyland
    Member
    Posted 4 years ago #

    Same here - I could really do with it defaulting to the No Link option as my users keep forgetting...

    No matter how many times I set it to 'no link' it always goes back to linking to the image.

    Any patches to fix this?

    Thanks.
    Andy

  8. s0what
    Member
    Posted 4 years ago #

    and I was afraid that I am the only one with this problem. I will try to update to 3.0b1, maybe this will fix the problem.

    Edit: upgrading to WP 3.0 beta1 fixed this problem.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.