WordPress.org

Ready to get started?Download WordPress

Forums

W3 Total Cache
How To: Revert to the last version of W3TC (34 posts)

  1. MarwanSalfiti
    Member
    Posted 3 years ago #

    I have been following the technical issues with the W3TC plugin and I love the thing but can't use it now because it is making the site break. Is there a step-by-step on how to revert to the older version of the plugin? Also, if I do this, will I lose all of my settings?

    Thanks in advance

  2. Go to http://wordpress.org/extend/plugins/w3-total-cache/download/

    Download the 0.9.1.3 version and manually upload the files.

  3. MarwanSalfiti
    Member
    Posted 3 years ago #

    thanks for the reply ipstenu... I did this already and i tried uploading the zipped plugin via the wp admin. unfortunately, the newer version of the plugin is still installed. so, do I delete the newer version first, then upload the older version?

    Also, am I going to lose my settings?

  4. Try a REAL manual upload :) Open up FTP and copy the files up.

    If that fails, delete. You SHOULD NOT lose your settings, but you can export them (bottom of the general page) first if you're worried.

  5. obrun
    Member
    Posted 3 years ago #

    You don't need to revert to the prior version. Apply the fix below. Press the buttons to reload the CDN and clear the browser cache after the fix. Try from a browser with and without you logged into the wordpress site.

    From @w3edge on twitter "users need to switch minify to manual minify mode".
    The fix seemed to work for me.

  6. MarwanSalfiti
    Member
    Posted 3 years ago #

    thanks again ipstenu. performing the upload now.

    Obrun, I actually tried that too, but it still seemed to be making things a bit funky. I still a newbie with this plugin, so I wanted to keep the guess work to a minimum.

    Thanks

  7. Jon Brown
    Member
    Posted 3 years ago #

    Toggling Minify from Auto to Manual seems to of fixed things for me... haven't throughly tested the site out but so far so good.

    THANKS @obrun

  8. Jason
    Member
    Posted 3 years ago #

    Reverted back to 0.9.1.3. Now I get asked if I am sure that I want to leave the page every time I try to save changes. Is this something to worry about?

    Thanks.

  9. Are you on Chrome?

  10. MarwanSalfiti
    Member
    Posted 3 years ago #

    wow, that was a very long work around. I went to the server, took down the new W3TC release and reinstalled the last version. That served a 500 Internal Server Error. I had to reboot the server, delete the .htaccess files and do a trial and error of install and delete with my plugins.

    Ultimately, the site/server are back up, the google page speed is back at 97/100 and the site is restored.

    I think I will hold off on the upgrade ;-)!

  11. JustinFYI
    Member
    Posted 3 years ago #

    Thank @obrun and @jb510 for checking it out as well. That did it for me. I found that the "compatibility check" acted a bit funky though...maybe a lightbox issue. Time to update the update I think.

  12. Yeah, the compat check and other help bits like that are acting up for everyone. Frederick said he's working on that.

  13. Jason
    Member
    Posted 3 years ago #

    @Ipstenu, that's interesting. I am not using Chrome. But I just tried using Firefox and Safari. It only happens with Firefox.

  14. Francis Rosário
    Member
    Posted 3 years ago #

    And the bug in servers running Nginx?

    In my case i see many Error 500 menssages after update.

  15. @Jason - I see it on Chrome, but only sometimes, and I think it's not W3TC, but Chrome being weird.

  16. Jason
    Member
    Posted 3 years ago #

    There's another update, 0.9.2.1

  17. Jason
    Member
    Posted 3 years ago #

    Just tried 0.9.2.1 on one of my WP installations. No go.

  18. JustinFYI
    Member
    Posted 3 years ago #

    I ran the update on another local backup of a WP site and voila! She's all good with the latest update (0.9.2.1). Thanks Frederick! And thanks for the heads up @Jason.

    Compatibility check still results in this error though:
    Parse error: syntax error, unexpected T_ELSEIF in C:\wamp2\www\website\wp-content\plugins\w3-total-cache\inc\lightbox\self_test.phtml on line 245

    Call Stack
    # Time Memory Function Location
    1 0.0008 795728 {main}( ) ..\admin.php:0
    2 1.4398 61624672 do_action( ) ..\admin.php:147
    3 1.4398 61626152 call_user_func_array ( ) ..\plugin.php:395
    4 1.4398 61626232 W3_Plugin_TotalCache->load( ) ..\plugin.php:0
    5 1.4399 61626856 call_user_func ( ) ..\TotalCache.php:804
    6 1.4399 61626904 W3_Plugin_TotalCache->self_test( ) ..\TotalCache.php:0

  19. chiefbrody2001
    Member
    Posted 3 years ago #

    I have tried the "simple" fix - "users need to switch minify to manual minify mode" - and it seems to have worked but haven't checked site thoroughly yet.

  20. The update fixed it for me (URL rewrite works fine, I can manually minify CSS and JS as I want).

    Lightbox is 90% fixed.

  21. WebEndev
    Member
    Posted 3 years ago #

    Version 9.2.1 does NOT work for me. No styling at all when the minify cache is enabled (in either manual mode, or not).

    From @w3edge on twitter "users need to switch minify to manual minify mode".

    This is not a fix. When you enable manual mode, it does NOT select any files for minification. You must add them. So by switching to manual mode, you are really minifying NOTHING unless you add files, and therefore you have no CSS styling issues.
    BUT you also do not have any minified CSS or JS files - so you're not getting any benefit.
    FYI... not a fix...

  22. When you enable manual mode, it does NOT select any files for minification. You must add them. So by switching to manual mode, you are really minifying NOTHING unless you add files, and therefore you have no CSS styling issues.

    Arguably that's how it's ALWAYS worked :) If you turn on minification on the old version, you had to add stuff. The 0.9.2.1 version defaults to manual, which is better than breaking with Auto, I think.

    The fix is:

    1) Change minification from auto to manual (manual is the new default)
    2) Add in your files to minify like you used to.

  23. WebEndev
    Member
    Posted 3 years ago #

    1) Change minification from auto to manual (manual is the new default)

    No problem. Have done this dozens of times trying to get it to work...

    2) Add in your files to minify like you used to.

    And HERE'S the problem. When I do add the files, it does NOT bring over any of my sites primary styling. The site is plain text. I verified the URI of my styles.css file, and it checks out.
    The issue is that version 9.2.1 is not creating all of the CSS files.
    See here

  24. That link has a bad param issue. Is that what you're having? It does matter.

    I'm thinking some issues are due to @import handling, personally, and I'm poking around trying to verify this. I can add SOME of my css files and it's fine, but others don't work at all.

  25. WebEndev
    Member
    Posted 3 years ago #

  26. No, I got to the page. What I meant was 'The error described on that page references a "Bad file param format". Is that YOUR problem?'

    Cause you didn't say and I'm just trying to get specifics ;)

  27. WebEndev
    Member
    Posted 3 years ago #

    No, not bad file param format.
    My issue is no CSS styling. No matter WHAT setting combination.
    Reverted to 9.1.3 and all is well though.

  28. Okay, see how that's different? ;)

    If you're stuck on '2) Add in your files to minify like you used to.' then you have to do some WORK and sort out WHICH css file is causing the problem.

  29. WebEndev
    Member
    Posted 3 years ago #

    2) Add in your files to minify like you used to.

    That's the problem, I do add in the files. They don't show up at all on the site. Missing, nada, no styling, bug, bug

  30. MobbyG
    Member
    Posted 3 years ago #

    I disabled minify on my install and it seems to have solved it on the outset. But obviously, something is wacky.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic