WordPress.org

Ready to get started?Download WordPress

Forums

How to restore my old version of wordpress? (7 posts)

  1. infocms
    Member
    Posted 3 years ago #

    Hello,
    I was using wordpress 3.0.1 but as I saw that the new version 3.0.2 is able, I just installed it.

    But now when I was trying to use a plugin that doesn't works in the new wp version, then I want to know if there is a way to get my old wp version back. If yes how?

    I didn't make a backup.

    Thank you.

  2. rainer23
    Member
    Posted 3 years ago #

    A new upgrade also upgrades the database. What exactly causes a plugin to not work anymore is rather difficult to answer. Only thing you can try is to install 3.0.1 and see if the changes make this plugin run again.
    Not sure if the database is also changed back by doing this? At any case, finally there must be an upgrade of this plugin available. Just one question, is it G-Lock Double Opt-in Manager? Which plugin is it actualy?

  3. Mike
    Member
    Posted 3 years ago #

    Try updating your plugin if there is one available.

    Try downloading 3.0.1 and pulling out the files mentioned at http://codex.wordpress.org/Version_3.0.2#List_of_Files_Revised into your install.

    As mentioned in the link, the DB version didn't change with 3.0.2.

    Before you try any of this, make a backup yeah?

  4. infocms
    Member
    Posted 3 years ago #

    Thank you rainer and Michael,

    The plugin is Myeasybackup and doesn't have an upgdate yet.
    And I don't understand your first question rainer: (is it G-Lock Double Opt-in Manager?)

    I will replace those files and see if that works.

    Thank you.

  5. govpatel
    Member
    Posted 3 years ago #

    I bit odd as I just updated and did not have any problem.
    I did make a backup on my server just in case I have problem.

  6. infocms
    Member
    Posted 3 years ago #

    Hi Michael, Thanks It is reverted now to 3.0.1 by replacing those files mentioned in the link.

    The only thing is not working now is the Myeasybackup plugin, after trying to installed from dashboard and also from downloading then activating from plugins list, and the error is:

    Plugin could not be activated because it triggered a fatal error.

    Script execution halted: require_once() [function.require]: Failed opening required 'C:/xampp/htdocs/wp-content/plugins/myeasybackup/inc/class.php5.addDir.php' (include_path='.;C:\xampp\php\PEAR') — 64

  7. rainer23
    Member
    Posted 3 years ago #

    Thanks infocms, just asked because G-Lock Double Opt-in Manager is my newsletter plugin and for our blog important that this works. Anyway upgrade done, no errors.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags