WordPress.org

Ready to get started?Download WordPress

Forums

How to remove /wordpress/ from every page URL? (2 posts)

  1. kttreasure
    Member
    Posted 1 year ago #

    Hey folks!

    I've been using WordPress for a while, but as a humble content generator, never as a developer. This is my first attempt at actually installing it on a site. I AM SO CLOSE...I just need a little nudge to finish this project.

    What needs to happen?

    My website: http://www.kensingtoninteriors.net/wordpress/

    Has /wordpress/ in every page URL, and I would love it to (obviously) not do that.

    Before you read on:
    I have tried following these instructions to no avail:
    http://www.networksolutions.com/support/how-to-change-wordpress-url/

    and

    http://codex.wordpress.org/Changing_The_Site_URL

    I spent about 4 hours on Sunday messing around with wp-config.php files and functions.php with no success. I am not a developer, so was relying on purely just well typed out directions on what specifically to change in these files, without really having a clue on what I was doing. All files are back to their default state at the time of install as of right now.

    What I think is the issue:
    When I used the Network Solutions set-up wizzard, it forced me during the install to choose a folder to install wordpress to. I suppose their preference is that you don't install wordpress to the root of your site. I have no choice, I have to select a folder (I can’t leave it blank and install to the root). So I went with what I thought made sense, and typed “wordpress”

    Boom, install finishes, and the blog goes live, but that pesky /wordpress/ is in all the URL's. I'm able to create and publish pages, and they show up correctly, but again, the cursed /wordpress/ in every URl.

    What the FTP looks like right now:
    The folder structure is: root / wordpress / wordpress (and then all the core files in the second level folder).

    The default WordPress Admin Settings:
    Wordpress Dashboard > General Settings

    WordPress Address (URL): http://www.kensingtoninteriors.net/wordpress/
    Site Address (URL): http://www.kensingtoninteriors.net/wordpress/

    I've changed the site address (URL) to just http://www.kensingtoninteriors.net, and everything saves....but when I load the homepage it still goes to kensingtoninteriors.net/wordpress/

    And if I build a page (for example a “contact us”) page...in WP-Admin I can correctly see that the permalink of my page is going to be http://www.kensingtoninteriors.net/contact-us/ and I am able to click “publish” and it saves...but I get a 403 error when I actually try to pull up that page.

    Issues remaining:

    • Getting /wordpress/ out of the page URL's
    • I suspect I need to move some folders on my FTP site so that there isn't the unneccesary rooting of root / wordpress / wordpress

    I am ok if the files are installed on the root. This is a pretty basic website without any customization (I'll install a theme and that's about it). Whatever you recommend!

    Yours, a humble content creator, in need of help,

    - Kristian

    kristian.sekse@gmail.com

  2. govpatel
    Member
    Posted 1 year ago #

Topic Closed

This topic has been closed to new replies.

About this Topic