WordPress.org

Ready to get started?Download WordPress

Forums

Sociable
[resolved] How to remove (via @sociablesite) /sociable/ blogplay.com from Twitter link? (17 posts)

  1. Angultra
    Member
    Posted 2 years ago #

    How to remove this? Every time something is tweeted using Sociable Classic, it appends:

    (via @sociablesite) /sociable/ blogplay.com

    to the end of the tweet. As much as I like Sociable, this just takes up way too many characters. I tried removing references in sociable.php but this had no effect. Thanks in advance.

    http://wordpress.org/extend/plugins/sociable/

  2. theonetruebix
    Member
    Posted 2 years ago #

    Is there really no way to fix this short of editing the plugin code ourselves, which then will just be overwritten the next time it's upgraded?

  3. Angultra
    Member
    Posted 2 years ago #

    Still can't figure it out,

    In Sociable Classic, the Twitter logo button still appends (via @sociablesite) /sociable/ blogplay.com to every tweet.

    The Tweet button / counter is even worse. It adds the URL a second time for some reason, in addition to the sociable stuff. So Tweets end up one big mess.

    Title + URL + "(via #sociablesite) *sociable* blogplay.com" + URL (again)

    Any advice?

  4. futurepocket
    Member
    Posted 2 years ago #

    Sociable is very tricky in adding this. The weird part is, I've edited the code and removed the code yet the output is still the same. Anyone mind telling me what code needs to be edited to actually get this out of my Tweets?

    This plugin shouldn't be allowed in the WordPress repository for FORCING links into Tweets.

  5. coolgizmotoys
    Member
    Posted 2 years ago #

    Glad I found this thread ... I thought it was just me! I have tried everything to get rid of duplicate url's in my Tweets (as well as the via #sociablesite ...and no luck. Help!

  6. rubbed
    Member
    Posted 2 years ago #

    Just uninstalled it after noticing this, thanks.

  7. Angultra
    Member
    Posted 2 years ago #

    I was finally able to fix the Twitter icon. Here's what I did:

    1) Remove references to sociablesite / blogplay from sociable.php
    2) Go to Sociable Options, click "Reset Sociable" at bottom (IMPORTANT)
    3) Button now just produces Title and URL

    However, this does not fix the Tweet button (with counter). Can't find references to the blogplay and duplicate URL in the .php files, hopefully someone can troubleshoot this. Here's the output:

    Title + URL + "*blogplay.com* blogplay.com" + URL (again)

    Even if we figure this out, they should really add the option to remove this in the UI, without going into the code.

  8. theonetruebix
    Member
    Posted 2 years ago #

    Right. But it's still just going to be overwritten the next time the plugin is updated. This needs to just be removed by the plugin authors, period.

  9. muddyh2o
    Member
    Posted 2 years ago #

    So, we all now know how to customize the link.

    Has anyone figured out how to embed a shortened URL in the prepared tweet?

  10. pauldardel
    Member
    Posted 2 years ago #

    same problem. Can't find how to remove the blogplay text from the tweets even when removing it from the php file and restarting the plugin...
    :-(

  11. fitz0019
    Member
    Posted 2 years ago #

    To remove the double link on the Twitter count button.

    1. Open sociable.php in root of the plugin
    2. Go to line 358 or search for TITLECOUNT
    3. You will see the 2 attributes data-text and data-url
    4. Replace them with data-text="TITLECOUNT" data-url="PERMALINKCOUNT". The tweet will now read TITLE - URL
    5. Go into WP Admin
    6. Select Sociable options and "Reset Sociable"
    7. Re select all your previous settings (annoying)
    8. Done.
    9. theonetruebix
      Member
      Posted 2 years ago #

      Again, however, that only works until the next time the plugin is updated. Then you have to do it all over again. Plugin author needs to fix this, period.

    10. fitz0019
      Member
      Posted 2 years ago #

      I understand this. But it's a quick fix and if you are under control of it you will have to remember. It's the only way for now.

    11. jacob-s
      Member
      Posted 2 years ago #

      This doesn't seem very in line with what users want from the plugin IMO.

      Switched to Social Sharing Toolkit which has no branding in tweets..

    12. Webtaurus
      Member
      Posted 2 years ago #

      thanks for posting the fix.

      Sociable is losing credit very fast this way.. It also seems a bit overambitious with the Skyscraper etc. keep things simple and they will break less often.

    13. sociable
      Member
      Plugin Contributor

      Posted 2 years ago #

      Hi guys,

      This twitter tags has been removed in the last upgrade.

      we don't want harm our users, these tags were used for stats and improve the plugin.

      Thanks for use Sociable

      [sig moderated as per the Forum Rules]

    14. ernohannink
      Member
      Posted 1 year ago #

      @sociable
      You corrected the tags in Twitter. However I still have an issue with the double link in a tweet. I have just changed sociable.php with the fix above and it works.
      Will you fix this with a next update please.

    Topic Closed

    This topic has been closed to new replies.

    About this Plugin

    About this Topic

    Tags