WordPress.org

Ready to get started?Download WordPress

Forums

How to remove unnecessary characters after blog url (8 posts)

  1. laxmi59
    Member
    Posted 2 years ago #

    Hi this is Rama.
    My blog URLS are not functioning properly with permalinks.
    My site URL
    http://localhost/wordpress/

    I got the following problem.(accepting following URL's also).

    http://localhost/wordpress/?/
    http://localhost/wordpress/page/2/?t=32/page/2/
    http://localhost/wordpress/page/2/?t=32/page/8/
    http://localhost/wordpress/page/2/?t=32/page/8/page/2/page/2/page/3/page/2/

    How can i remove these UN-necessary special charaters. pls help me

    [ Please do not bump, it's not permitted here. ]

  2. loughcorrib
    Member
    Posted 2 years ago #

    You have saved to folder wordpress on your machine.They are page id's change your permalinks in admin and try that first. Though frankly your last url has me a bit perplexed.

  3. laxmi59
    Member
    Posted 2 years ago #

    Thanks for the reply. I already enabled permalinks at the time of WordPress installation. Just now I tested current site unexpectedly. It is also not showing any issue. please see the following URL'S. of the current WordPress site.

    http://wordpress.org/showcase/page/2/?t=32/page/2/
    http://wordpress.org/showcase/page/2/?t=32/page/8/page/2/page/2/page/3/page/2/

    Please help to fix this Problem.

    Thanks in Advance

  4. loughcorrib
    Member
    Posted 2 years ago #

    First of all I use wordpress on a hosted server so I set these up myself, and have not used wordpress.org. However having stated that I suspect that your link could be wrong check out this.
    <link href="http://wordpress.org/showcase/
    yoursitename
    /your page/post" rel="canonical">
    Have a look hope this helps. In the mean time maybe someone who uses .org might pop in here.

  5. laxmi59
    Member
    Posted 2 years ago #

    Actually my site url is http://www.affiliateprograms.com/blog/
    I enabled permalinks in wordpress admin like
    Custom Structure /%postname%/
    and my .htaccess file contains the following

    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteRule ^index\.php$ - [L]
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>

    What I have to change to solve the problem of http://www.affiliateprograms.com/blog/page/2/?t=32/page/8/page/2/page/2/page/3/page/2/

    Thanks in Advance

  6. loughcorrib
    Member
    Posted 2 years ago #

    Really confused with this. Probably staring us in the face. What happens if you change your rewrite base to / and rewrite rule to /index.php[L]

  7. laxmi59
    Member
    Posted 2 years ago #

    I modified .htaccess file as per your suggestions. Now it will skip the blog/page/2/ from given url.

    Main url:
    http://www.affiliateprograms.com/blog/page/2/?t=32/page/8/page/2/page/2/page/3/page/2/

    After .htacces changes. it will redirect to following url
    http://www.affiliateprograms.com/?t=32/page/8/page/2/page/2/page/3/page/2/

  8. loughcorrib
    Member
    Posted 2 years ago #

    I just noticed that the number of pages corresponds to the number in articles are you using a plugin Not at my pc so can't look Frankly this has me scratching my head Normally something like this is simple Your pages are nested behind one another I presume they are named and your permalink structure is working Best of luck I'll. call back
    Ps also identify I'd= page 2

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.