WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] How to remove theme author's link (12 posts)

  1. beeby
    Member
    Posted 12 months ago #

    I have a WordPress multisite installation and so far all is running well but one of my sub-sites is using a theme with the theme author's link and the powered by WP link.

    Under a standard WP site, I do remove this by going to Editor but it seems the Editor has disappears when I switched to multisite.

    Do any one know how to get rid of this links either by using a plugin or something else?

    Here is the theme I am using! http://gazpo.com/2012/07/max/

    Thanks in advance for your kind help!

  2. David Sader
    Member
    Posted 12 months ago #

    Theme editor is still there, only available to SuperAdmin, though.

    /wp-admin/network/theme-editor.php

    Dashboard->Network Admin->Themes->Editor

    Creating and activating a Child Theme based on your Parent theme may be useful if you have tinkerin' to do.

    Hiding a few divs here and there can be done with Custom CSS Plugin as well.

    #div_2b_hid {
    display: none !important;
    }
  3. beeby
    Member
    Posted 12 months ago #

    Thanks David!

    Under themes, I only have Installed Themes > Add New. No Editor appearing.

  4. David Sader
    Member
    Posted 12 months ago #

    WP3.5.1 Network enabled, and you are logged in as SuperAdmin AND go to "/wp-admin/network/theme-editor.php"?

    Look at your installed themes list table and click the "edit" link there, too.

    wp-admin/network/themes.php

  5. beeby
    Member
    Posted 12 months ago #

    The themes list table not showing any 'edit' option. wp-admin/network/theme-editor.php is showing an error.

  6. David Sader
    Member
    Posted 12 months ago #

  7. beeby
    Member
    Posted 12 months ago #

    yea! "You do not have sufficient permissions to access this page."

  8. David Sader
    Member
    Posted 12 months ago #

    Then you are not logged in as SuperAdmin or something else is limiting your role while logged in.

    You need edit_themes capability which in Mulisite Network is only with the SuperAdmin.

  9. beeby
    Member
    Posted 12 months ago #

    I am logged in as SuperAdmin. It could be one of the plugins restricting me. eg Better WP Security [ http://wordpress.org/extend/plugins/better-wp-security/

  10. David Sader
    Member
    Posted 12 months ago #

    Try a read here.

    http://wordpress.org/support/topic/you-do-not-have-sufficient-permissions-to-access-this-page-125?replies=9

    Does the plugin add constant to wp-congig.php?

    define( 'DISALLOW_FILE_EDIT', true );

    If so, then turn the security plugin setting back on/off so you can then edit files once again.

  11. beeby
    Member
    Posted 12 months ago #

    Yes it does! I'm giving it a try.

  12. beeby
    Member
    Posted 12 months ago #

    All done David. The Better WP Security plugin is what disabled the themes and plugins editor.[Turn off file editor in WordPress Back-end]...This option needs to be off to access the editors.

    Thanks :)

Reply

You must log in to post.

About this Topic