WordPress.org

Ready to get started?Download WordPress

Forums

Fast Secure Contact Form
How to remove "enter email second time" text (7 posts)

  1. jsherk
    Member
    Posted 2 years ago #

    Hi

    Great plugin! Just installed it and got it working in a few minutes and have already rated it 5 stars!

    About the only option I cannot find is how to completely remove the "Please enter your E-mail Address a second time" text. I feel it is redundant and would like to get rid of it.

    Thanks

  2. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    On the form edit page you can add new labels for any text on the form.
    Find the setting for that label and add this to the field:
    <!-- -->

  3. jsherk
    Member
    Posted 2 years ago #

    Thanks Mike!

    That removes the text, but it stills leaves a blank between the "E-Mail Address again:" text and input text box. I might need to hardcode a change to remove it?

    Looking at the page source, I see this:

    <div style="text-align:left;">
    <span style="font-size:x-small; font-weight:normal;">Please enter your E-mail Address a second time.</span>
    <br>
    <input id="si_contact_email2_1" type="email" size="40" value="" name="si_contact_email2" style="text-align:left; margin:0;">
    </div>

    The three things that would need to be done in order enable/disable it thru CSS would be (1) Move the BR tag inside the span tag, and (2) assign a class name to the span, and (3) add a section in the Style area so you could hide/unhide the span. If the span is hidden, then the BR tag would not come into effect and the blank line would not appear!

    So something like this:

    <div style="text-align:left;">
    <span class="some-new-class">Please enter your E-mail Address a second time.<br></span>
    <input id="si_contact_email2_1" type="email" size="40" value="" name="si_contact_email2" style="text-align:left; margin:0;">
    </div>

    And then in Style you would have a new entry for "some-new-class" with this in it:
    font-size:x-small; font-weight:normal;

    Thanks

    EDIT: Had to change my br tags to BR so they dont get removed!

  4. jsherk
    Member
    Posted 2 years ago #

    Using v3.0.3.2, and on line 291 of si-contacr-form-display.php I added a display:none; to the style, and on line 293 I swapped the [/span] and [br/] so they are [br/][/span] now.

    This workaround solves the problem for me, although hopefully it can somehow be incorporated into the next version!

    Thanks

  5. jsherk
    Member
    Posted 2 years ago #

    How do I make this a "New Feature" request?

    Thanks

  6. Mike Challis
    Member
    Plugin Author

    Posted 2 years ago #

    I can add it to my list. But I am not able to add more settings until I split some into tabed categories because the settings page has too many fields right now. It might be a month or two. I am about to go on vacation.

    Mike

  7. jsherk
    Member
    Posted 2 years ago #

    That will be great if you can add it to a future feature list!

    And I think tabs would be a good feature as well! The settings page is definitely long, but that's a good thing!

    Thanks for great plugin!

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic