WordPress.org

Ready to get started?Download WordPress

Forums

Oenology
[resolved] How to remove 'oenology' from section headers (12 posts)

  1. SWP_Coach
    Member
    Posted 2 years ago #

    I love the oenology theme, but the word 'oenology' is prefixed to section titles, like:

    Oenology Recent Posts
    Oenology Archives
    Oenology Categories
    Oenology Tags
    Oenology Post Formats
    Oenology Links by Cat

    How to add either custom prefix (such as "SWP") or leave it out all together so it looks like this:

    Recent Posts
    Archives
    Categories
    Tags
    Post Formats
    Link by Cat

    Thanks.

    http://wordpress.org/extend/themes/oenology/

  2. Xam 1.0
    Member
    Posted 2 years ago #

    Simple fix: change the title of the widgets in dashboard > appearance > widgets. If you just drop some widgets in the widget-area and leave the title blank it uses Oenology as prefix. Example: you want use the Oenology Recent Posts widget, drop it in the widget-area and name it Recent Posts. Problem solved.

  3. Chip Bennett
    Theme Review Admin
    Theme Author

    Posted 2 years ago #

    Xam 1.0 that's exactly it!

    The main reason I prefixed the default titles was to differentiate between the output of the customized Widget and its core-Widget counterpart.

    Simply use the "Title" field in the Widget, to rename each Widget as you see fit.

    Thank you, both, for using Oenology!

  4. SWP_Coach
    Member
    Posted 2 years ago #

    Thanks to both Xam 1.0 and Chip Bennett. I was able to add my own title.

    Thanks especially to Chip for creating a very clean, minimalistic yet functional WP theme.

    I went to appearance -> widgets, and I dragged 4 widgets into Sidebar Right (Calendar, Recent Posts, Archives, and Categories). They appear on the blog page fine, but the old 'Oenology' ones are there too. I can't delete them by dragging them out of any of the sidebars because I don't see them there!

    Pl see http://www.superwealthprogram.com/blog

    What to do?

    Thanks.

  5. Chip Bennett
    Theme Review Admin
    Theme Author

    Posted 2 years ago #

    Try adding Widgets to Sidebar Left :)

    And I appreciate the kind words. I'm always looking for any feedback, to know how I can make the Theme better, or better meet users' needs.

    (p.s. have you found the "Oenology Reference" admin section helpful at all?)

  6. SWP_Coach
    Member
    Posted 2 years ago #

    Hi Chip,

    I tried what you suggested: removed widgets from Sidebar Right, and added them to Sidebar Left.

    The widgets with custom titles show up on the left sidebar, but the oenology titled widgets magically appear on the right sidebar! Moreover, the Calendar now appears twice, plus Oenology links by cat and Meta also.

    So, I have two sidebars on the right (one called left and the other called right). The left is the correct one I want the right one is the wrong one. ;-)

    See: http://www.superwealthprogram.com/blog

    Sorry to be a bother, but any help would be appreciated!

    Thanks,

    Kiran

  7. Chip Bennett
    Theme Review Admin
    Theme Author

    Posted 2 years ago #

    You need to put Widgets in both Sidebar Left and Sidebar Right. :)

    What you're seeing are the default Widgets that are output if the user has not added any Widgets in the sidebars.

    If you would like to change this behavior, so that the sidebars don't output anything at all if the user has not added any Widgets, I would recommend creating a Child Theme, and adding the files sidebar-left.php and sidebar-right.php. Inside each of these files in the Child Theme, remove (or comment-out) all the calls to the_widget().

  8. SWP_Coach
    Member
    Posted 2 years ago #

    Wow, this is getting into programming!

    Not sure how to create a child theme, so I took the easy way out and just commented out the_widget() code in the sidebar-left.php. So, now, it is working fine, except that there is a large blank space. I'd have liked the blog post area to expand and occupy that space. Am I asking for too much?

    Thanks for your patience.

  9. Chip Bennett
    Theme Review Admin
    Theme Author

    Posted 2 years ago #

    Wow, this is getting into programming!

    It may seem that way, but really it's not; I promise! Making a Child Theme is pretty simple.

    Not sure how to create a child theme, so I took the easy way out and just commented out the_widget() code in the sidebar-left.php.

    Please note that those changes will get over-written the next time the Theme is updated. I wrote a tutorial specifically for how to create an Oneology Child Theme; give it a read. I would recommend putting those two template files into the Child Theme; then, you never have to worry about them being over-written!

    So, now, it is working fine, except that there is a large blank space. I'd have liked the blog post area to expand and occupy that space. Am I asking for too much?

    Have you tried changing the single blog post layout, either the default layout, or per-post?

    Go to Dashboard -> Appearance -> Oenology Settings -> Layouts, and see if one of the alternate layouts suits your needs better.

    Thanks for your patience.

    My pleasure! I'm glad to know that people are using and benefiting from the Theme!

  10. washingtonmike
    Member
    Posted 2 years ago #

    I'm using oenology for static pages only, not running a blog.

    I'd like to remove the displays from the right sidebar which currently are "oenology links by cat" and "meta". How might that be done, please? Thanks, Michael

  11. washingtonmike
    Member
    Posted 2 years ago #

    I should also mention they don't appear on the home page, just on the second page.

    Also appears the calendar in the same way. Can that be removed as well?

  12. Chip Bennett
    Theme Review Admin
    Theme Author

    Posted 2 years ago #

    @washingtonmike:

    (For future reference, please start new topics for unrelated issues. Doing so both facilitates all support questions being answered/resolved, and also helps other users find answers to similar questions/issues.)

    I'm a bit confused by your question. If you want to display a sidebar with your own, selected Widgets, just apply Widgets as desired, via Dashboard -> Appearance -> Widgets. If you want the archive index pages not to display any Widgets whatsoever, then change the archive index page layout to "One Column", via Dashboard -> Appearance -> Oenology Settings -> Layout.

    Let me know if this resolves your issue.

    Thanks!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic