WordPress.org

Ready to get started?Download WordPress

Forums

How to remove Non Latin Characters from Permalinks? (6 posts)

  1. Manitu
    Member
    Posted 7 years ago #

    Hi!

    What I need is to have ONLY LATIN characters in permalinks?

    Because when a post title is in Russian for example - permalink is also uses russian charackters, so the link result is like this:
    http://blog.domain.com/%d1%80%d1%83%d1%81%d1%81%d0%ba%d0%be%d1%8f%d0%b7%d1%8b%d1%87%d0%bd%d1%8b%d0%b5-%d0%b3%d0%b8%d0%bf%d0%b5%d1%80%d1%81%d1%81%d1%8b%d0%bb%d0%ba%d0%b8-%d0%b1%d0%b5%d1%81%d1%8f%d1%82-%d1%80%d1%80%d1%80%d1%8.html
    but better they look like:
    http://blog.domain.com/russlojazychnye-ssylki-besjat.html

    How can I do that?

  2. moshu
    Member
    Posted 7 years ago #

    There used to be a plugin: RusToLat
    http://www.google.com/search?q=rustolat
    (the original site is down but you may be able to find another place to download it)

  3. Manitu
    Member
    Posted 7 years ago #

    It works!

    Thank you!

  4. moshu
    Member
    Posted 7 years ago #

    с удовольствием :)

    Glad it worked. Could you, please, mark this as "resolved"?

  5. Ovidiu
    Member
    Posted 6 years ago #

    sorry to revive this old post, but I just installed this plugin, still no go :-( it still inserts permalinks like %d0%b1i%d1%82va/ into the slug field, and on the options page of the rus to lat plugin all I see are weird characters like:

    лас�.�.ебки RusToLat

    �.�. Хе�.�.�.�. в�.�.�.а�.Ѧ с�.анда�.�., пе ке�.е�.еХу �.уд�.�. п�.еи�.веди�.сѬ �.�.анс�.и�.�.�.а�.иѬ �.аге�.евкев.

    лас�.�.ебки е�.нев�.�.н�..
    м�.еи�.веди�.Ѧ �.�.анс�.и�.�.�.а�.иѮ в с�.анда�.�.�.:

    I have no clue whats wrong...

  6. Ovidiu
    Member
    Posted 6 years ago #

    I found the error. I had copy and pasted the plugins code via ssh - tried again uploading the zip and uncompressing and it seems to have worked now :-)

Topic Closed

This topic has been closed to new replies.

About this Topic