WordPress.org

Ready to get started?Download WordPress

Forums

How to remove magic quotes? (5 posts)

  1. WPChina
    Member
    Posted 8 years ago #

    For some reason in the subjects (Ititles) of my blogs, all the apostrophes and quotation marks are turning into magic quotes. I have tried all different ways of copying/pasting normal quotes into the field, but after I publish they turn into magic quotes. In fact, the original quotes I paste in are not even magic quotes, but somehow they turn into it... any idea what I'm doing wrong?

    And, btw, who in the world invested magic quotes and why did they do it? I have Googled this issue and not many poeple have sound advice or solutions on how to fix it in WP, so I hope someone here has an answer. (I suspect the magic quotes are a MSFT invention, no?)

  2. skulled
    Member
    Posted 8 years ago #

    There is an issue with that was discussed before, a simple work around is to use HTML entity code instead of putting the actual quotes in your subject ..

    For using the double quote use this: " -> "
    Single quotes are given by: & #39; [No space between '&' and '#'] -> '

    Hope that helps ...

  3. This is a result of the wptexturize() function. Remove it from your default filters file in /wp-includes/ or get one of the plugins out there that'll remove the filter. Search, you'll find them.

  4. WPChina
    Member
    Posted 8 years ago #

    Hmmm, actually I am using the plugin here:
    http://dev.wp-plugins.org/wiki/TextControl

    But maybe I am not using it correctly... it seems like all the settings I use for it still make it come out magic_quotes. Any idea what set of features on the plugin I should utilize to ensure it works well?

    Tks!

  5. sur_vismayam
    Member
    Posted 8 years ago #

    sir,
    i m arun can may i perform magic trick on urs stage.

    plz help me
    thank you

    arun sharma
    sur_vismayam@yahoo.co.in

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags