WordPress.org

Ready to get started?Download WordPress

Forums

How to remove link to Hostgator (8 posts)

  1. Karen2010
    Member
    Posted 4 years ago #

    Hi

    I've set up a blog using the minamalist theme.

    At the bottom of my site it has "Web Hosting by Hostgator".

    Please can you tell me how I can remove this.

    Thanks

  2. Aaron
    Member
    Posted 4 years ago #

    Open footer.php in Theme Editor and find the code for that and remove it.

    If that doesnt work then give a link to your theme so I can see it.

  3. Karen2010
    Member
    Posted 4 years ago #

    Thanks for your advice. Here's my link:

    http://blogging-espionage-review.net/

    I have edited the footer.php and this is what I have left:

    <hr />

    </div>

    <!-- Gorgeous design by Michael Heilemann - http://binarybonsai.com/kubrick/ -->
    <?php /* "Just what do you think you're doing Dave?" */ ?>

    <?php wp_footer(); ?>
    </body>
    </html>

  4. Aaron
    Member
    Posted 4 years ago #

    Looks like you installed using fantastico

    I never done this so not sure if you are allowed to remove it but if you go to

    wp-includes/general-template.php

    Then do a search for "by HostGator" I'm guessing you will find the code you need to remove.

    Maybe somewhere in here

    function get_footer( $name = null ) {
    	do_action( 'get_footer', $name );
    
    	$templates = array();
    	if ( isset($name) )
    		$templates[] = "footer-{$name}.php";
    
    	$templates[] = "footer.php";
    
    	// Backward compat code will be removed in a future release
    	if ('' == locate_template($templates, true))
    		load_template( WPINC . '/theme-compat/footer.php');
    }
  5. Karen2010
    Member
    Posted 4 years ago #

    Yes, I used fantastico.

    I've looked everywhere for hostgator when I went into "editor" and then in each "template" but can't see it. I wonder it would come under something else?

    I've never done this before so not really sure what I'm looking for.

  6. Aaron
    Member
    Posted 4 years ago #

    Ok I had a bad guess since I never used Fantasico to install.

    But heres the answer. Go to plugins and disable the Hostgator one.

    I know your kicking yourself now. I would be :)

  7. Kim09
    Member
    Posted 4 years ago #

    It looks like when you install wp with fantastico in Hostgator you have automatically hostgator plugin.

    Also see this thread, just deactivate the plugin which is called hosted by hostgator.com

  8. Karen2010
    Member
    Posted 4 years ago #

    haha, that's brilliant, thank you so much for your help!

    Now to get my layout sorted...

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.