WordPress.org

Ready to get started?Download WordPress

Forums

How to remove featured image from post content? (12 posts)

  1. bradleyagnew
    Member
    Posted 9 months ago #

    I want to set logos as featured images for my posts as it is a portfolio, this is fine displayed as a thumbnail but when I view the post WordPress automatically enlarges the image to fit the width of the page. How can I keep the logo as a thumbnail but remove it from the post content entirely? Thanks in advance.

  2. bcrose
    Member
    Posted 9 months ago #

    Great timing! I am also looking for a way to keep the full sized image from overwhelming the portfolio pages.

  3. dejliglama
    Member
    Posted 9 months ago #

    Hi

    You need to change how you theme's single.php file works. Depending on your theme, that file might be named something else like single-portfolio.php.

    In there the featured image is output. Maybe using :

    <?php the_post_thumbnail( $size, $attr ); ?>

    Remove this, or define which size you want it to output:

    http://codex.wordpress.org/Function_Reference/the_post_thumbnail

  4. alchymyth
    The Sweeper & Moderator
    Posted 9 months ago #

    when I view the post WordPress automatically enlarges the image to fit the width of the page

    this depends on the used theme;

    please post more details:
    http://codex.wordpress.org/Forum_Welcome#Include_as_much_information_as_possible

    @bcrose
    please start your own topic - you likely have a different theme;
    http://wordpress.org/support/forum/how-to-and-troubleshooting#postform
    or post directly in your theme's forum.

  5. bradleyagnew
    Member
    Posted 9 months ago #

    Perhaps I was unclear, here are further details:
    I am using 'Overgrowth' theme by 'IrishMiss' - version 1.0.9

    I want a portfolio of clients with logos as thumbnails.

    This is fine, but if you open a portfolio page the client logo is automatically resized to the width of the page.

    I do not want to disable resizing across the site, but I want to remove the logo from the portfolio page - not the grid of client logos.

    If you can suggest I solution, it would be appreciated.

  6. dejliglama
    Member
    Posted 9 months ago #

    Have you tried my suggestion?

  7. alchymyth
    The Sweeper & Moderator
    Posted 9 months ago #

    there is a style in http://www.agnewsolutions.co.uk/wp-content/themes/agnewsolutions/assets/css/generic/packed.css that is causing the image to scale to full width;

    this is what Firefox' web developer add-on shows:

    /* Line 8 */
    .image-resize.w
    {
      width: 100%;
      height: auto;
    }

    as that file is all in one line, I can't help with details; consider to contact the developer of your theme for support.

  8. bradleyagnew
    Member
    Posted 9 months ago #

    @dejiliglama
    I have taken a look at the 'single.php' and could not find a way to remove the image from post content:

    <?php
    /**
     * Single Template
     *
     * @package MissFramework
     * @subpackage StartUp Theme
     */
    global $irish_framework_params;
    
    get_header();
    $layout = new miss_page_layout($layout = miss_page_layout(), $location = 'views/single', $type = 'single', $template = get_post_type() );
    $layout->miss_render_page_layout();
    get_footer();
    ?>

    [Moderator Note: Please post code & markup between backticks (not single quotes) or use the code button. Your posted code may now have been permanently damaged by the forum's parser.]

    I could not see how I could disable the post from appearing in the post content from this code alone.

    @alchymyth
    Thanks for your feedback, I was able to edit the 'packed.css' to set the image size to its automatic size. However, this is only a temporary solution and I am looking to completely remove it. Can you think of CSS for '.image-resize.w' to disable the image in post content completely? Thanks for all your input!

  9. alchymyth
    The Sweeper & Moderator
    Posted 9 months ago #

    CSS for '.image-resize.w' to disable the image in post content completely?

    try this CSS:

    .portfolio_single .single_content.portfolio .image-resize.w { display: none; }

    not tested for side effects ...

  10. bradleyagnew
    Member
    Posted 9 months ago #

    @alchymyth
    Unfortunately implementing these changes causes the image to be removed from thumbnails as well as the post itself, is there any way that I could simply exclude it from the post but keep it as a thumbnail on the portfolio page?

  11. dejliglama
    Member
    Posted 9 months ago #

    I'm sorry - I don't know this themes build structure. Perhaps it would be wise to ask the theme author for the location of the portfolio single page template.

  12. SIT-groupbd
    Member
    Posted 3 months ago #

    I want to set image as featured images for my posts, this is fine displayed but when I want to delete post, post delete but not delete a upload image from upload file. How can solve it? Please solution me...

Reply

You must log in to post.

About this Topic