WordPress.org

Ready to get started?Download WordPress

Forums

Preference Lite
[resolved] How to remove Date, Author and Category from Preference Lite Version: 1.8.5 (15 posts)

  1. dnnytn
    Member
    Posted 5 months ago #

    Hi, I would like to remove the post information at the top of every post and page. I have seen post where i can add dl.gj-article-info {display: none;} into style.css, but it is not working for me. Pls advice.

  2. StyledThemes
    Member
    Theme Author

    Posted 5 months ago #

    Actually it should work, but that code is incorrect as it should be this:

    dl.article-info {
    display: none;
    }
  3. Watergal
    Member
    Posted 3 months ago #

    I want to do this too, but tried adding this code to the child style.css. I could not find a dl.article line, so added the code above under article styles. (Maybe I am not using the child correctly...I copied the entire style.css into child, then made any modifications).

  4. StyledThemes
    Member
    Theme Author

    Posted 3 months ago #

    Actually, the correct way to do this is to only copy over into the child theme's style.css what you plan to change. You also want to make sure that any css you copy over or plan to add to the child theme's style.css goes below this line:

    /* Add your css changes below this line */

    **I also just noticed a goof up on my part when I uploaded the last update to this theme. I left some styles in the child theme css for the .menu-toggle classes. These should be removed.

  5. Watergal
    Member
    Posted 2 months ago #

    Changes to my child theme don't seem to be taking. I removed all the excess, leaving in only what I changed. Here is the post page - the post info is still showing. (Somehow...I also changed the font of the menu and can't seem to get the default back.)
    http://www.monctonwriters.ca/wordpress/for-business/find-a-writer/

  6. StyledThemes
    Member
    Theme Author

    Posted 2 months ago #

    That is odd... I just went to your site link and in my browser I did the display none code as I have above and it worked on both pages, the summary and the full post view of your post. Perhaps clear your browser's cache and cookies and see if that works.

  7. Watergal
    Member
    Posted 2 months ago #

    Nope. didn't work. I still have date/author/categories in both summary and full post. I've tried all of these, as noted above (and looked at it in Firefox and Chrome, just in case):

    dl.article-info {
    display: none;
    }

    .article-info dd {
    display:none;
    }

    .status-date {
    display:none;
    }

  8. StyledThemes
    Member
    Theme Author

    Posted 2 months ago #

    Ah...now I know why. You don't have your child theme active. You obviously already did theme options with colours etc., so for "only" css changes, you can use a plugin instead. If you have jetpack, it has an Edit CSS plugin you can use, otherwise you can try a plugin called Simple Custom CSS which lets you add CSS changes to your theme being used. You would then drop that code I gave you into that and then it will work. If you decide to use the child theme, when you activate it, WP will see it as a new theme activation and you will need to redo your theme options and widgets.

  9. Watergal
    Member
    Posted 2 months ago #

    Oddly enough, I thought I had activated it...and lost all my widgets, colours, etc. But regardless, this solved the problem. Thank you.

  10. Watergal
    Member
    Posted 2 months ago #

    It worked initially, and then something changed and the post info came back. I installed the simple custom css, and added this code.

    dl.article-info {
    display: none;
    }

  11. StyledThemes
    Member
    Theme Author

    Posted 2 months ago #

    Instead of using the child theme (your choice though), you can install a plugin called Simple Custom CSS which lets you add your own CSS like above, to it. If you use Jetpack, it also has an Edit CSS plugin built in. If you go back to the parent theme being active, your widgets and theme options should return.

  12. Watergal
    Member
    Posted 2 months ago #

    I am using the Simple Custom CSS. This worked initially, then I'm not sure what changed, but the line came back.

  13. StyledThemes
    Member
    Theme Author

    Posted 2 months ago #

    I just went to your site and see the custom css file in your source code. It should be working, but try this:

    dl.article-info {
    display: none !important;
    }
  14. Watergal
    Member
    Posted 2 months ago #

    that worked. I'm sorry for taking your time...

  15. StyledThemes
    Member
    Theme Author

    Posted 2 months ago #

    No worries... glad that one worked.

Reply

You must log in to post.

About this Theme

About this Topic