WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] [closed] How To: Remove Date and Time from Posts and Comments in Glossy Stylo Theme (11 posts)

  1. Crozon1
    Member
    Posted 1 year ago #

    I'm looking for a way to remove the date and time from both the posts and the comments in the Glossy Stylo theme. My site is: crozon.ca

    I was able to remove the date from the top of the post, but it is still located in the "This entry was posted on" field at the bottom as well as in the comment section.

    I've read almost every available how to on the subject, and the instances that everyone recommends to look for in the code are not present in my theme.

  2. To get rid of the metadata at the bottom of the post, insert this into your custom css:

    .postmetadata {
        display: none;
    }

    Then, to remove it from your comments, add this also:

    .commentmetadata {
        display: none;
    }

    Should look like this:

    .postmetadata {
        display: none;
    }
    .commentmetadata {
        display: none;
    }
  3. Crozon1
    Member
    Posted 1 year ago #

    Thanks Josh - unfortunately that was something that was already attempted, and it didn't work

  4. It will work :)

    Perhaps you are not adding it to the proper place? Where exactly did you paste the code I provided?

  5. Crozon1
    Member
    Posted 1 year ago #

    Hi Josh,

    The .commentmetadata code was already present in the css style sheet - I simply changed it to display: none; - before I posted this question, but it didn't make any changes. It was located below the .comment section

    For the .postmetadata I placed it below the .post section

  6. Crozon1
    Member
    Posted 1 year ago #

    Anyone else know how to remove the date from posts and comments?

    In fact, I really don't need this whole blurb at all:

    "This entry was posted on Friday, November 26th, 2010 at 3:15 pm and is filed under freelance writing. You can follow any responses to this entry through the RSS 2.0 feed.You can leave a response, or trackback from your own site."

    But I would still like to remove the dates from the comments: http://crozon.ca/blog/im-on-a-horse

  7. Crozon1
    Member
    Posted 1 year ago #

    I added the code again - and it worked! I was having issues with my WP Total Cache - changes I was making didn't update, once I turned off the plugin it all works out - thanks Josh!

  8. No worries.

    I believe WP Total Cache has an option to "empty" the site cache at will. Look for an option that says "Clear Cache" or "Empty Cache". You shouldn't need to deactivate the plugin... rather just use the option to clear the cache after you make adjustments.

  9. prohollyking
    Member
    Posted 1 year ago #

    Josh, just gotta say you're amazing! I was looking to solve this problem for myself and your fix did the trick!

  10. mbdblogger
    Member
    Posted 12 months ago #

    It is very simple. You just have to remove this coding from your theme. <?php the_time('F jS, Y') ?>. it will be in Index.php and Single.php. Remove from the files. Just make sure you have backup of original file if something wrong happens.

  11. WPyogi
    Volunteer Moderator
    Posted 12 months ago #

    @mbdblogger - modifying theme files is not good advice. Changes like that should only be made in a child theme.

Topic Closed

This topic has been closed to new replies.

About this Topic