WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] How to Remove Comments and Time Stamps on Specific Pages (6 posts)

  1. agfreesafety
    Member
    Posted 2 years ago #

    Hi, I'd like to remove the Timestamps and Comments from all "Pages" for this site, but I'd like for them to remain on blog posts.

    I saw this old thread on the topic, however I don't see anything regarding time stamps in my page.php or index.php files.

    I also looked at the Codex on timestamps, but I couldn't figure out where the code was that is referenced there.

    I tried to figure this out on my own, so I highlighted the Timestamp section using Firebug on one of the pages that I'd like to remove the timestamp and comment section on to look for clues. I couldn't figure out what to change, and what actually created the timestamp, though.

    Question:

    1. How can I remove the timestamp and comments section on all pages, while keeping them on blog posts?

  2. vtxyzzy
    Member
    Posted 2 years ago #

    I believe that adding this to the end of style.css will do what you want:

    body.page .entry-meta {
       display: none;
    }
  3. agfreesafety
    Member
    Posted 2 years ago #

    I believe that adding this to the end of style.css will do what you want:

    body.page .entry-meta {
    display: none;
    }

    Thank you! Any idea of how I can get rid of the comments section for the same pages?

    According to this document, unchecking the third option (
    "Allow people to post comments on new articles"), but I did that, and they're still showing up.

    ...unless this only applies to articles posted "after" I change the setting, perhaps?

  4. agfreesafety
    Member
    Posted 2 years ago #

    Nope... I just re-saved this page, and the comments section is still showing up.

  5. vtxyzzy
    Member
    Posted 2 years ago #

    You are correct, it only applies to new articles.

    I think the following will change the older ones, but I have not actually used it.

    • Go to Admin->Posts->All Posts and click the checkbox on the left of each one you want to change.
    • Then select 'Edit' in the dropdown for 'Bulk Actions' and click 'Apply'.
    • In the dropdown for 'Comments', choose 'Do not allow' and click 'Update'.
  6. agfreesafety
    Member
    Posted 2 years ago #

    That did it. Thank you. Didn't even know that screen existed.

Topic Closed

This topic has been closed to new replies.

About this Topic