WordPress.org

Ready to get started?Download WordPress

Forums

Breadcrumb NavXT
How to remove "/category/" from breadcrumb url? (3 posts)

  1. trishahdee
    Member
    Posted 1 year ago #

    I am using this plugin on a client site but the category pages do not use the /category/ in their urls. I have read through a number of the support threads here and nothing I've tried works. Example of the problem is:

    This returns the correct page:
    http://website.com/blog-category-slug/

    But this goes to a 404 page:
    http://website.com/category/blog-category-slug/

    How do I get your plugin to use the page url?

    http://wordpress.org/extend/plugins/breadcrumb-navxt/

  2. John Havlik
    Member
    Plugin Author

    Posted 1 year ago #

    Using pages for categories is not how WordPress was designed to operate. Categories are supposed to link to the category archive page, which WordPress generates for you. The link Breadcrumb NavXT uses is generated by WordPress, if you've moved the category archive page and the links are wrong, that means you haven't set up everything correctly for moving the archive.

    If you really want to use pages you need to select the "parent" option under the "post hierarchy" option in the settings page for Breadcrumb NavXT. Then you'll need to go to every post and assign it a parent page or post (a plugin such as Post Parents can help).

  3. trishahdee
    Member
    Posted 1 year ago #

    Just to be clear: I didn't move the archive, and the links that the plugin creates has the actual word "category" in the link url. I wasn't saying that "/category/" represented where the name of the category was in the url.

    I finally determined that the "problem" happened because of the custom page templates I am using for the blog categories.

    The way I fixed the problem is with templates. The site only has a few blog categories, each with a unique template design assigned to a page. This is why the links did not have the /category/ in them because they are actually pages! So, I used the category template in my child theme and recreated the unique designs for each category. Now both urls work :D

    Thanks for the quick reply. It is appreciated.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic