WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] How to remove Author's name from posts? (16 posts)

  1. IslandOwl
    Member
    Posted 2 years ago #

    What CSS will over-ride the php that makes it so the author's name is below the title of every post? I am the only one posting on this blog and my name does not need to be there. The blog is VividlyClear.com. I am using the Brunelleschi theme by Kit MacAllister.

    I have tried:
    .postauthor {
    display:none;
    }

    And
    #entry-author-info {
    display:none;
    }
    #entry-author-info #author-avatar {
    display:none;
    }
    #entry-author-info #author-description {
    display:none;
    }
    #entry-author-info h2 {
    display:none;
    }

  2. pncl
    Member
    Posted 2 years ago #

    u have to delete author name using css
    author vcard{
    display:none;
    }

    delete name then go in function.php file and delete there

  3. Nasir Zia
    Member
    Posted 2 years ago #

    Hi,
    You will have to edit your functions.php file in your theme's folder..
    You can find the code for this on line 151
    sprintf( '<span class="author vcard"><a class="url fn n" href="%1$s" title="%2$s">%3$s</a></span>',

    thanks

  4. IslandOwl
    Member
    Posted 2 years ago #

    So there is no way to edit it with CSS?

    I don't mind editing the php really but I will have to go back in and do it again each time there is an update for the Brunelleschi theme. I was hoping not to have to do that.

    TIA!

  5. Nasir Zia
    Member
    Posted 2 years ago #

    Well There is a way..
    If you want to remove the entire line completely then use this.

    .entry-meta {
    display:none;
    }

    This will remove by Viv Ilo Posted on May 12, 2012 .

  6. Nasir Zia
    Member
    Posted 2 years ago #

    or use

    .meta-sep {
    display:none;
    }
    
    .vcard{
    display:none;
    }
    
    .author{
    display:none;
    }

    If you just want to remove the Post Author Name.

    thanks

  7. IslandOwl
    Member
    Posted 2 years ago #

    No, that did not work. I am trying some other options but am about ready to call it a night and get to bed. Thanks for your attempts to help.

    I added Brunelleschi onto the tags so maybe someone will be familiar with this theme. It is a WONDERFUL theme!!

  8. wpreser
    Member
    Posted 2 years ago #

    Hi,

    Open your main CSS file and add the following code, in the last position of the file:

    .sec-authors {
    display: none;
    }

    It should work.

  9. IslandOwl
    Member
    Posted 2 years ago #

    No, that did not work either! Darn! He has this well hidden!

  10. IslandOwl
    Member
    Posted 2 years ago #

    @Nasir (or anyone else),

    I've uploaded the php from the area that I think you mean I would need to edit; but it is not line 151. It is lines 332 - 347 at least how I am looking at it. The code is at: http://pastebin.com/8qhWKhZW

    There is another conversation from about 8 months ago HERE but when I tried to make the change Harry suggested it crashed the site - which is not a big deal because I am messing with this on a dummy domain that I own. I will make the change on my real site when I am sure I know what I am doing.

  11. alchymyth
    Forum Moderator
    Posted 2 years ago #

    the css suggestions by @Nasir Zia should work;

    if you have problems to see changes to style.css immediately, try to clear the browser cache - 'reload' the web page (a few times), try to press 'CTRL F5', might be different for your your browser.

    same css approach:
    .entry-meta .meta-sep, .entry-meta .author { display: none; }

  12. IslandOwl
    Member
    Posted 2 years ago #

    Thank you everyone. When I put in @alchymyth's css just the way he had it, it worked!!

  13. IslandOwl
    Member
    Posted 2 years ago #

    This issue is resolved. Forgot to check it 2 weeks ago.

  14. Darasy
    Member
    Posted 1 year ago #

    Im working on this same issue....Where should I put this bit of code :

    ".entry-meta .meta-sep, .entry-meta .author { display: none; }" that @alchymyth suggested.... is this the right code?
    Any help would be appreciated. Thanks

  15. alchymyth
    Forum Moderator
    Posted 1 year ago #

    @Darasy

    that depends on your used theme;

    please post your own topic and add details like the name and download link of your theme, and possibly a link to your site.

  16. Snehal Patel
    Member
    Posted 1 year ago #

    @ alchymyth I also need to know how can I remove my name from site.. Pleas let me know where should I change code?

    Have a look at my code and let me know.

    http://pastebin.com/j2ij7tXn

Topic Closed

This topic has been closed to new replies.

About this Topic