WordPress.org

Ready to get started?Download WordPress

Forums

How to remove a vertical line?? (11 posts)

  1. OohlaLaw
    Member
    Posted 1 year ago #

    Hi,

    As ridiculous as this sounds, I cannot remove a vertical line that's on my site. It's oohlalaw.com and there is a vertical line in middle of the content on most of my pages. I moved the sidebar from the right to the left and I suspect it has something to do with that. However, I've looked through the stylesheet multiple times and cannot find the border css language that is causing this. I've spent hours trying to figure it out, but no success. The vertical line is not on my homepage, http://oohlalaw.com, or full width page, http://oohlalaw.com/full-width/, but it is on every other page, including single posts and pages.

    I would greatly appreciate your help.

  2. Andrew
    Forum Moderator
    Posted 1 year ago #

    Add this to your CSS;

    .taxonomy .center, .singular .center {
     background: none;
    }
  3. OohlaLaw
    Member
    Posted 1 year ago #

    Thank you for your response. I added the code but it did not get rid of the line. Any other suggestions?

  4. Andrew
    Forum Moderator
    Posted 1 year ago #

    Yeah, don't add the code at the top of the stylesheet. Add it to the very bottom.

  5. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Not visible -- make sure you've cleared your browser and any other caches.

  6. Andrew
    Forum Moderator
    Posted 1 year ago #

    Here's the issue, WPyogi http://snag.gy/lsnaU.jpg , along with the issue of overriding CSS styles as the code was entered at the top of the CSS file.

    Oddly the original poster has not noticed the styling that resolves the issue, already applied to the home page http://snag.gy/d3yiU.jpg

  7. OohlaLaw
    Member
    Posted 1 year ago #

    @Andrew Nevins

    Thank you. That did the trick. But how did the line get there in the first place? I don't see any css border language that would cause it?

    @WPyogi

    Thank you for your response. It was definitely there even after I cleared cache. Andrew's advice solved the problem though.

  8. Andrew
    Forum Moderator
    Posted 1 year ago #

    Look at what background: none; means http://www.w3schools.com/css/css_background.asp to understand what the issue was.

  9. OohlaLaw
    Member
    Posted 1 year ago #

    Oddly the original poster has not noticed the styling that resolves the issue, already applied to the home page http://snag.gy/d3yiU.jpg

    I'm a beginner at coding and can figure out basic things, but I'm still learning. I bought this theme from colorvila.com and I have posted to their forums and received no answer (posted 4-5 days ago). The theme had a broken homepage (did not display properly), which I had to fix myself. I fixed the homepage visually but it still won't validate. I don't advise that anyone buy from these people. I then changed the sidebar from right to left and that's when the vertical line came into play. I thought it was a border somewhere in css, but I guess I was wrong. I do understand what background: none; means, but I didn't think that was the problem. I was trying to hunt down a border, which I could not find.

    Thank you for help.

  10. Andrew
    Forum Moderator
    Posted 1 year ago #

    It's really not fair to take advantage of the WordPress.org, open-source community forums for support with themes you've paid for. You're going against the principles of the free community by buying a theme and therefore are excluding yourself from support.

    For support with commercial themes, contact your theme's vendors.

  11. OohlaLaw
    Member
    Posted 1 year ago #

    Andrew, I didn't know about this. Didn't realize there's anything wrong with asking for help here regarding a paid theme. I'm new to this.

    As I mentioned, the theme's vendor is horrible and I've already tried posting to their forums and sending them emails. They have not answered anything. And the theme came broken to begin with. Seriously, this should not be a theme to pay for since free themes work and this one did not out of the box.

    So if I can't get help here, I'm completely out of luck to make this thing work at all. I'm not trying to offend anyone. I like the open source community and would like to take part in it. I just need help and have no where else to turn since the theme provider is completely ignoring my multiple forum posts and emails.

Topic Closed

This topic has been closed to new replies.

About this Topic