WordPress.org

Ready to get started?Download WordPress

Forums

How to reduce CPU usage? (4 posts)

  1. cohahaco
    Member
    Posted 2 years ago #

    Hi,

    I'm hitting the limit of my host's CPU usage several times... I've installed the W3 Cache Plugin: http://wordpress.org/extend/plugins/w3-total-cache/

    But since then it has hit 100 mCPU more often... I had object cache and database cahce unchecked before, should I check them?

  2. webjunk
    Member
    Posted 2 years ago #

    Try disabling plugins (temporarily) and see if it resolves it.
    Also try the default theme.
    Could be some errant code.

  3. cohahaco
    Member
    Posted 2 years ago #

    If I disable my plugins, will it show the changes within minutes? I'm hitting 100 mCPU like almost every hour to several hours in between. Its never consistent...

    I can't leave the plugins disabled for long because I need them for specific needs. Here are the plugins I have activated:

    akismet
    disqus comment system
    contact form 7
    lightbox gallery
    register plus redux
    peters login redirect
    user role editor
    wp pagenavi

    Are there any that can possibly cause on the max cpu?

  4. webjunk
    Member
    Posted 2 years ago #

    First disable your cache. Then You only have to disabled the plugins for a minute or two. Not sure how you are monitoring CPU though. If using top you will know right away. Some host interfaces are delayed.
    Also be sure to try the twentyten theme in case the issue is related to the theme.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags