WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] How to put posts on homepage (13 posts)

  1. Smexy
    Member
    Posted 2 years ago #

    Hey guys, I recently got a hold of a nice premium-like theme but it doesn't have the option to set posts on the homepage. What I see now are Recent news which are like 5 of the latest posts. Then you can add to see Highlights and Portfolio items. That's cool and all but I need to see the posts on the home page.

    This is the theme : http://www.wpexplorer.com/adapt-free-responsive-wordpress-theme

    So what should I edit so that the posts show on the home page exactly as they do here in this category? http://plakat-sieger.de/category/allgemein/

    Please help, it's really urgent , I would LOVE and ADORE some help from you guys.

  2. keesiemeijer
    moderator
    Posted 2 years ago #

    Try this:
    Make a backup of your theme's index.php. Duplicate your theme's category.php (if the theme has one) and rename to index.php.

  3. Smexy
    Member
    Posted 2 years ago #

    That sounds like a really great idea but the theme doesn't have a category.php dangit :P
    Here is what it DOES have http://i.imgur.com/6iKGg.png

  4. keesiemeijer
    moderator
    Posted 2 years ago #

    You could also try it with archive.php

  5. plie65
    Member
    Posted 2 years ago #

    Activating links on pages and posts, rather than on the blogroll sidebar.
    Just wrote my second post, actually just a link, but when I view the page it is not active, not clickable. Where have I gone wrong? It is on the home page. Maybe that is the wrong place for posts.

    I use the visual editor,don't think I'm capable of mastering code. Can someone help, please?
    Thanks.

    http://www.thisbespokelife.com

  6. keesiemeijer
    moderator
    Posted 2 years ago #

  7. Smexy
    Member
    Posted 2 years ago #

    EDIT: I did something wrong, i'll do the right thing now, let's see if renaming Archive.php works

  8. keesiemeijer
    moderator
    Posted 2 years ago #

    Did you duplicate the archive.php and renamed it index.php and replaced it for the old index.php in your theme folder? Seems the error comes from the index.php in the root of your website. Then you can switch between the static front page and your old index.php

  9. Smexy
    Member
    Posted 2 years ago #

    IT'S ALIVEEE!!!
    Thank you, it works.

  10. Smexy
    Member
    Posted 2 years ago #

    Is there any way to add this as an option somewhere? Like a switch?
    If not then it's OK. I can just re-add the old index php

  11. keesiemeijer
    moderator
    Posted 2 years ago #

    You could make a static front page with a custom page template that is the same as archive.php (or now index.php) for this. Then you can switch between the static front page and your old index.php

  12. Smexy
    Member
    Posted 2 years ago #

    Thank you very much. You were most useful Kessie.
    Best regards
    -Darius

  13. keesiemeijer
    moderator
    Posted 2 years ago #

    No problem. Im glad you got it resolved :-)

Topic Closed

This topic has been closed to new replies.

About this Topic