WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] How to open external site through WordPress site with same domain name? (9 posts)

  1. christiehawkso
    Member
    Posted 11 months ago #

    Hi guys,

    I am currently working on my portfolio site. I have a few files with different HTML - such as some websites that I created during school year. I want to be able to show it. I put the folder in FTP where it should be able to open a separate website (with same domain). I save all of my project under "project" folder:
    http://www.mydomain.com/project/project1.html
    http://www.mydomain.com/project/project2.html
    http://www.mydomain.com/project/project3.html
    etc.

    On the home page, I have a list of project with images with "Launch Site" buttons beneath. When I click "Launch Site" (with same link as above) to see a project that I have been working on. But it did not show the website that I created, instead it show a WordPress page that said "Page not found".

    Do you know how to fix this issue? I would be appreciate that you can help me out! Let me know if you need more details. I however can't share my actual link because it is not live yet.

    Many thanks,
    Christie

  2. Aaron Dicks
    Member
    Posted 11 months ago #

    Hi Christie
    Are you using http:// before your link?
    Aaron

  3. christiehawkso
    Member
    Posted 11 months ago #

    Hi Aaron,

    Yes, I use http:// before the link.

  4. Aaron Dicks
    Member
    Posted 11 months ago #

    Maybe you could post the link but replace some of the letters with *** so we can see the issue?

  5. christiehawkso
    Member
    Posted 11 months ago #

    Okay, I will show you the link for temporary:
    http://www.christiehoeksema.com/

    Please click a box called "utici" on portfolio section in home page, then it will expand and show the slider with content. You will see the button "Launch Site" - click it. It should go to different HTML page - outside of WordPress.

  6. Aaron Dicks
    Member
    Posted 11 months ago #

    Hi Christie
    What code is producing that URL? Are you tracking outbound links or something similar?

  7. Aaron Dicks
    Member
    Posted 11 months ago #

    Oh wait, you need to remove the trailing slash from the end of the URL ('/')
    If you post the code producing the URL I can help you

  8. Aaron Dicks
    Member
    Posted 11 months ago #

    Here's a quick way to trim the trailing slash

    $url = rtrim($url,"/");

  9. christiehawkso
    Member
    Posted 11 months ago #

    Ah, of course, I wished I noticed that sooner. I removed the last slash on the end of the URL and it works perfectly. Thanks for your help! :)

Reply

You must log in to post.

About this Topic