WordPress.org

Ready to get started?Download WordPress

Forums

FlexiCache
[resolved] How to not serve a cache version of certain page (3 posts)

  1. camafive
    Member
    Posted 1 year ago #

    Hi i love your plugin but i need little help with something, how do i make the plugin to not cache a single page. What i need is to always serve fresh version of website homepage . How would i do it?, also i have question about google. i mean does google know when i post something new? i send sitemap to google but i don't know if it notices about the content.

    http://wordpress.org/extend/plugins/flexicache/

  2. simon.holliday
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    You can add a "no-store" condition to prevent FlexiCache from caching a page based on a number of rules. How this works is explained in the documentation which comes with the plugin: http://your.website.com/wp-admin/options-general.php?page=flexicache&section=documentation#flexicache-doc-configuration (change your.website.com to your WordPress hostname)

    To prevent FlexiCache from caching the homepage, create a new no-store rule as follows:

    Source: $_SERVER
    Key: REQUEST_URI
    Match Type: Equals
    Value: /

    This will prevent FlexiCache from caching anything where REQUEST_URI="/", which is the URI of the home page.

    Once you have done this, FlexiCache will no longer cache that page. Bear in mind that if the page has already been cached, it will continue to be served up until the cached item expires, so you may also want to clear the cache to see this configuration working immediately.

    Hope that helps!

    Si.

  3. camafive
    Member
    Posted 1 year ago #

    Wow let me try it, i uninstalled your plugin because of that.
    Thanks

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic