WordPress.org

Ready to get started?Download WordPress

Forums

Google XML Sitemaps
How to noindex the sitemap.xml file? (3 posts)

  1. Brin Wilson
    Member
    Posted 6 months ago #

    Hiya,

    What's a way to noindex the generated sitemap.xml file - to stop it appearing in the SERPs?

    Thanks,
    Brin
    P.s. really love this plugin!

    http://wordpress.org/plugins/google-sitemap-generator/

  2. liton1980
    Member
    Posted 6 months ago #

    You can do this by adding below code to your .htaccess file

    <IfModule mod_rewrite.c>
      <Files sitemap.xml>
       Header set X-Robots-Tag "noindex"
      </Files>
     </IfModule>

    Change sitemap.xml with the name of your XML sitemap.

  3. KeepItSimpleWD
    Member
    Posted 6 months ago #

    I have a related question. My client was messing around with the Google XML site map V3 for QTranslate plugin and he unchecked one of the basic default options. The effect "seemed" positive, but I'd like to know what it really means/does. Prior to this the site was showing the robots.txt message, not the Meta description for the site and, he said ten minutes after he'd made the change, it showed up.

    He unchecked the basic default setting:
    __ Add sitemap URL to the virtual robots.txt file.
    The virtual robots.txt generated by WordPress is used. A real robots.txt file must NOT exist in the blog directory!
    See background below.

    Is that the right choice, or wrong? or what is the effect of unchecking this box.

    We had been working on the site for a few weeks with the privacy settings set to discourage search engines form indexing or showing the site. When we were done, I unchecked the privacy settings. then linked to the new site from my site, and did a few other things to essentially signal google to re-index the site, so it would show the meta description etc. I know it can take from 3 days to three weeks for this change to occur.

    Over the weekend, my client changed that option as noted above and said that right afterwards, the site (which had been showing the robots.txt privacy message in google) switched and showed up with the meta description as we want it to.

    I'm wondering if it was just coincidental, or what the best option is?
    the site is http://www.pennremodeling.com

Reply

You must log in to post.

About this Plugin

About this Topic