WordPress.org

Ready to get started?Download WordPress

Forums

TinyMCE Advanced
How to make TinyMCE Advanced default editor instead of HTML? (6 posts)

  1. pixelwind
    Member
    Posted 1 year ago #

    Hi, I've tried the standard add_action filter for making tinyMCE the default editor instead of HTML, but that doesn't work for the advanced version.

    I'm trying this in my functions.php file:
    add_filter( 'wp_default_editor', create_function('', 'return "tinymce_advanced";') );

    Is this correct or is there another way to do this?

    Thanks!

    http://wordpress.org/extend/plugins/tinymce-advanced/

  2. pixelwind
    Member
    Posted 1 year ago #

    Btw, the above code is not working, I didn't mention that. Any ideas for a fix?

  3. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 1 year ago #

    The Visual editor (TinyMCE) is default on new WordPress installations. Has been for some time now.

  4. pixelwind
    Member
    Posted 1 year ago #

    Yes, I know this, you didn't read my question, or I'm not being clear.

    I'm using "TinyMCE Advanced" plugin, not the original TinyMCE. I'm also using Responsive Theme by ThemeID, so maybe that's coming into play here. Whenever I open a page/post, or update a page/post, it always goes back to the HTML editor, even if I'm working the the visual editor. I have to keep clicking the visual editor tab to edit further, total pain. So, the question is how do I make it default to the visual editor tab rather than the HTML tab?

    Hope that's clearer.

    Thanks.

  5. Andrew Ozz
    WordPress Dev
    Plugin Author

    Posted 1 year ago #

    Much clearer now, thanks.

    The TinyMCE Advanced plugin only extends the default configuration of TinyMCE, it doesn't change which editor is default.

    In core that setting is stored in a cookie every time you click on the "Visual" or "Text" button and later saved in the DB. A plugin or a theme can change/disable this but don't see why. You can see what's there by pasting this in the browser console: getUserSetting('editor') and set it with setUserSetting('editor', 'tinymce').

    To check on the PHP side, paste this somewhere in edit-form-advanced.php:
    <?php echo get_user_setting('editor'); ?>.

    And you can set that by adding:
    set_user_setting('editor', 'tinymce');
    in a function running on 'admin_init'.

  6. pegrlom
    Member
    Posted 4 months ago #

    Please help me with WP 3.8.1:

    I have localhost site1 - TinyMCE Advanced with Easy Response, NextPage,
    TinyMCE Advances Formats and Styles.

    Works perfectly and I see all rows if the Tiny Advance.

    When I try with the local site2, site3, I do not see the 3rd row.
    I followed your advice - installed console
    get_user_setting =>tinymce

    Is there a way to get these missing rows here?

    Thanks very much

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic