WordPress.org

Ready to get started?Download WordPress

Forums

WP Favorite Posts
How to make this work with w3 total cache, for non-logged in users ? (4 posts)

  1. southcast
    Member
    Posted 11 months ago #

    Dear plugin author, These are few methods that I tried to follow in the W3tc settings.

    1. w3tc > Page Cache > Rejected cookie setting - wp-favorite-posts (I guess this is the cookie key, letme know if I am not supposed to do that).

    2. w3tc > Page Cache > Never cache the following pages: /my-favorites-template-page-url

    3. I have event unchecked the W3tc > Page cache > cache posts page option.

    The above settings do not work for non-logged in users. Click on the button only refreshes the page and nothing happens, the post does not get listed on the template page. Please let me know what I am doing wrong. Everything works fines with w3tc deactivated or the admin logged in though. I tried wp-super-cache same situation. Please help.

    http://wordpress.org/plugins/wp-favorite-posts/

  2. Koff
    Member
    Posted 10 months ago #

    Hi,

    I have the same problem with the WPEngine caching.

    Any ideas?

    Koff

  3. southcast
    Member
    Posted 10 months ago #

    I actually ended up abandoning the w3tc plugin or any other caching plugin and am using custom codes instead. My site is now far more faster and scalable without code bloats these plugins cause.
    Although, in your case you should get in touch with your guys at wpengine.

  4. Huseyin Berberoglu
    Member
    Plugin Author

    Posted 10 months ago #

    Hello,

    Please try to add "wp-favorite-posts.php" to "Never cache the following pages" section.

    I'm using wp favorite posts plugin with W3 Total Cache also but i don't allow non-registered users to use plugin. If it is possible for you, you can use "only registered users can favorite" option.

Reply

You must log in to post.

About this Plugin

About this Topic