WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] How to make index page the default page (11 posts)

  1. francelos
    Member
    Posted 8 years ago #

    Hi
    If I use this adrress:
    http://www.mypage.com/myblog/index.php
    go direct to my blog, but with this address: http://www.mypage.com/myblog
    I am redirected to the index!
    Who can help me, please, how to control this situation?
    Thanks and regards
    Luis

  2. moshu
    Member
    Posted 8 years ago #

    What do you have in the Options > General in the two URI fields?

  3. francelos
    Member
    Posted 8 years ago #

    I have in the two URI fields:
    WordPress address (URI): http://mypage.com/myblog
    Blog address (URI): http://mypage.com/myblog

    Thanks for your answer.
    Luis

  4. moshu
    Member
    Posted 8 years ago #

    Can we get a working link? mypage/myblog isn't really helpful in troubleshoting...

  5. francelos
    Member
    Posted 8 years ago #

  6. moshu
    Member
    Posted 8 years ago #

    Contact urgently your host and tell them to make index.php a valid index file.

  7. francelos
    Member
    Posted 8 years ago #

    That´s all I need to do I suppose?
    Thanks and have a good weekend.
    Regards
    Luis

  8. orrr
    Member
    Posted 8 years ago #

    I have a similar problem, I think. I have WordPress set up on an Intranet web site. It's called NWKWEB. When I click on Pages -> About I get http://nwkweb/?page_id=2

    Also when I click on a post it says: http://nwkweb/?p=4#respond.

    What have I done wrong in the installation?
    Thanks

  9. moshu
    Member
    Posted 8 years ago #

    That's how it is supposed to be. Question: do you see that Page or the post?
    If it is an intranet we cannot see anything, I guess.

  10. orrr
    Member
    Posted 8 years ago #

    I fixed it by adding index.php to the end of the URL for the blog. I think it's on the options -> general page. This is strange because when I've done this before, I lost all my themes and the page looked crappy. Oh well, It least this works now.

    Thanks for the quick response and Sorry for taking your time.
    Rodger

  11. moshu
    Member
    Posted 8 years ago #

    Well, that's not really a fix - because, as you just said, could cause other problems. The two URIs in the Options > General are not supposed to end in a file name but a folder name.
    You may try to convince the intranet admin to make index.php a valid index file.

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags