WordPress.org

Ready to get started?Download WordPress

Forums

How to make database writable in phpmyadmin ??? (8 posts)

  1. Yukon Cornelius
    Member
    Posted 2 years ago #

    The last developer on my wordpress site made the database read-only for security, since the content is static.

    Now we need to make some changes, but we're unable to access the dashboard, even as Administrator.

    I just want to change the permissions so the databse is read - write.

    Can anyone point me in the right direction?

    Thanks in advance.

  2. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    You can get to the db through the host. If you can convince them you own the site that they host (maybe you pay them?) they might be able reset the db password. It normally is just the login and password for signing into the host. Then you can reset the dashboard password.

  3. Yukon Cornelius
    Member
    Posted 2 years ago #

    Hi kmessinger,

    Thanks for taking the time to answer. I have access to the database through phpmyadmin, and I can log in ok, but I'm unsure how to change the permissions so the database is no longer read only.

    Any idea how to change permissions on the database itself?

    Yukon

  4. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    Privledges are set on the first page of MySQL for each user. It should be right where you pick which db to open.

  5. Yukon Cornelius
    Member
    Posted 2 years ago #

    Thanks kmessinger. That makes sense, but there is nothing on that page of phpadmin that allows me to change user privileges.

    Under databases, it gives the option 'create a database', then it lists the existing two databases.

    Below where it gives the option to create a database, it says 'no privileges' in red, but no option to change it.

    In my directAdmin panel, when I click on 'mysql management' it also lists my databases there, and offers the option to change privileges. I have changed all of the privileges to 'yes', but it's still not letting me into the dashboard (I just get the 'You do not have sufficient permissions to access this page.' message).

    Am I missing something?

    Yukon

  6. Yukon Cornelius
    Member
    Posted 2 years ago #

    ps kmessinger: when you are speaking of priveleges, you are talking about mysql user privileges, not wp_user right?

    I have administrator rights on the wordpress site, and I have double checked my permissions in the database under wp_usermeta.

    Thought I'd mention that in case our wires are crossed.

    Cheers,

    Yukon

  7. kmessinger
    Volunteer Moderator
    Posted 2 years ago #

    kmessinger: when you are speaking of priveleges, you are talking about mysql user privileges, not wp_user right?

    Yes. For me, in the control panel at my host I have a MySQL Database. I click on that and that is where users, new db, privledges, backups, etc. happen. Also from here I click on which db I want to open (I have several) and then phpMyAdmin opens the db.

    You need to find the screen where you create the databases. Look for a help file at the host on how to create a db.

    I have administrator rights on the wordpress site

    If this was correct you would not get 'You do not have sufficient permissions to access this page.' message. Once you gain access to the db you can check your wp privleges there.

  8. Yukon Cornelius
    Member
    Posted 2 years ago #

    Once again, cheers for the help, kmessinger!

    I guess I do have access to the privileges then. But granting them all to myself doesn't seem to help trying to access wordpress.

    I do have access to the database, and I have created a new aministrator account in the wp_user table and the metuser table.

    But it's still not possible to access the dashboard (I still get the 'You do not have sufficient permissions to access this page.' message).

    I was told by the previous developer that this is because the database is set to readonly.

    So any idea how to change this setting? Is it just a matter of finding a directory and changing chmod, or is it something I have to do in phpadmin?

    Apologies if this is confusing. Your help is really appreciated.

    Yukon

Topic Closed

This topic has been closed to new replies.

About this Topic