WordPress.org

Ready to get started?Download WordPress

Forums

How to link post author to site page (9 posts)

  1. djb377
    Member
    Posted 2 years ago #

    I can't figure out how to make my post author link to a site page. Right now when someone clicks on my name they get a "page not found". Can someone help please?

  2. esmi
    Forum Moderator
    Posted 2 years ago #

    Unless you provide a link to a page demonstrating the problem, no one will be able to offer much in the way of assistance.

  3. djb377
    Member
    Posted 2 years ago #

    Oops sorry. Here's a sample post from my blog.

    http://www.spinestrong.com/back-pain-should-you-get-x-rays-spine-strong/

    Under "leave a reply" my name is listed as the author but goes to a "page not found". Where is this suppose to go? And can I link it to a page on my site?

    Thank you

  4. esmi
    Forum Moderator
    Posted 2 years ago #

    As I'm not you and I'm not logged in, I can't see your name under "Leave a reply". What I suspect you are seeing is a line that tells you that your are logged in as 'admin' (or whatever your login name is). It's not a link to all posts made by you. It's a link to your profile in the back end of the site. Why it's not working as it should, I couldn't say right now. Could just be some bad theme coding...

    Try resetting your custom permalinks back to the default setting via Settings -> Permalinks. If this works, then review Using_Permalinks before setting a custom permalink structure back up again.

  5. djb377
    Member
    Posted 2 years ago #

    Nevermind. That only shows when I'm logged in.

  6. djb377
    Member
    Posted 2 years ago #

    Thanks you.

  7. djb377
    Member
    Posted 2 years ago #

    Sorry the problem is actually in my emails to subscribers. When a subscriber receives an email update of my current post it appears with the post title and post author along with a generic avatar to the left and then the content below. The post author when clicked goes to the page not found. This can be fixed by resetting my permalinks? Also, how can I get this generic avatar removed and my business logo displayed instead?

    Thank you for your patience. I'm still in learning mode. lol

  8. esmi
    Forum Moderator
    Posted 2 years ago #

    That's a plugin, Try posting in its dedicated forum.

  9. djb377
    Member
    Posted 2 years ago #

    ok great. thank you

Topic Closed

This topic has been closed to new replies.

About this Topic