WordPress.org

Ready to get started?Download WordPress

Forums

Customer Area
[resolved] How to keep the submenu opened when editing a page or file (7 posts)

  1. brasofilo
    Member
    Posted 1 year ago #

    Hi, Vincent, c'est moi again :)

    It's not very elegant, but I use this jQuery trickery in a plugin of mine to keep the CPT sub-menu opened when we moved it inside another menu.

    Here, it's adapted to work with Customer Area:
    https://gist.github.com/brasofilo/5608193

  2. Vincent Mimoun-Prat
    Member
    Plugin Author

    Posted 1 year ago #

    Cool. I was annoyed by that but I did not have time to look for a workaround. I will integrate your script in the next release. Thanks a lot.

  3. Vincent Mimoun-Prat
    Member
    Plugin Author

    Posted 1 year ago #

    One question: on your site, which menu item causes troubles for you?

    On my test installs (WP 3.6b3 and WP 3.5.1), I only experience trouble with the "private file categories". The rest ("private files" and "new private file" are shown correctly). Correct?

  4. Vincent Mimoun-Prat
    Member
    Plugin Author

    Posted 1 year ago #

    Fixed in 1.6.3

    Leave a review if you like the plugin :)

  5. brasofilo
    Member
    Posted 1 year ago #

    Today, I wrote on G+ before seeing you already responded here and already implemented the stuff!
    ¡Si, señor, olé!

    I'm running 3.5.1. The issue happens for Private Pages and Files when editing an existing item:
    /wp-admin/post.php?post=POST-ID&action=edit

    When creating a new item (/wp-admin/post-new.php) it opens ok.

    Re: Private File Category
    I haven't updated to your new commit, I'll take a look afterwards and report back.

    Yes, I'll surely review and would appreciate yours as well ;)

    Take a look at this Easy Digital Downloads thread, it is affecting your plugin too.

    cheers!

  6. brasofilo
    Member
    Posted 1 year ago #

    What I was experiencing still happens
    - when you're editing an existent File or Page, the menu does not open
    - it works ok when adding a new item, I suppose the query var post_type=SLUG makes this work without hacks

  7. Vincent Mimoun-Prat
    Member
    Plugin Author

    Posted 1 year ago #

    Hi,

    I released a fix today (1.6.4) that should correct that.

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic