WordPress.org

Ready to get started?Download WordPress

Forums

How to keep dashboard from going white (8 posts)

  1. sciofrel
    Member
    Posted 4 months ago #

    I keep having the annoying problem of my wp-admin going to white when I make any changes (ie. plugins activation, plugin settings, etc.). My max memory is set to 256M, so I don't think that is the problem.

    Any suggestions? Any way for me to find out what the problem(s) is/are?

    I have 1 domain and 3 subdomains.
    http://sciofrelief.com
    http://cell.sciofrelief.com
    http://abstracts.sciofrelief.com
    http://justscience.sciofrelief.com

    Any help is greatly appreciated!

  2. catacaustic
    Member
    Posted 4 months ago #

    There's two ways to find out what's going wrong. You can use either, or both:

    1. Set define('WP_DEBUG', true); in your wp-config.php file and you'll see the errors on the screen (Just change it back when you've got it fixed)
    2. Look at your sties error logs to find what the actual error message is

    That's the only way that you'll find what's wrong. Find the error and only then you'll be able to solve the problem.

  3. sciofrel
    Member
    Posted 4 months ago #

    How is this error possible with 256M memory max?

    Fatal error: Allowed memory size of 37748736 bytes exhausted (tried to allocate 122880 bytes) in /home/sciofrel/public_html/abstracts/wp-admin/includes/post.php on line 101

  4. Saravanan
    Member
    Posted 4 months ago #

    It could be that there is plugin using huge amounts of memory. Could you try disabling the plugins and check if you still have the problem?

  5. catacaustic
    Member
    Posted 4 months ago #

    Look at the error message...

    37748736 bytes / 1024 / 1024 = 36MB. That's how much memory is available. If you've tried to raise the limit to 256MB then it hasn't worked. How have you tried to set the limit so far?

  6. sciofrel
    Member
    Posted 4 months ago #

    Mainly in the php.ini file. On ManageWP under Server Information, it says I have 256M.

  7. catacaustic
    Member
    Posted 4 months ago #

    I've done that too, and found out that on some servers it doesn't work. Local php.ini files are very easy to block for server admins, and it's a standard setting on most hosting server systems to not allow them.

    If you want to see exactly what your site can use, create a file called info.php and add this to it:

    <?php phpinfo ();

    Upload that to your server, and go to www.yoursite.com/info.php and you'll be able to see all of the settings that are available for your site. I'll guarantee that that page says that you have 36MB of memory available.

    If the php.ini file hasn't worked, you can also try to do it in your .htaccess file. Just add this somewhere outside of the WordPress directives:

    php_value memory_limit 256M

    Again, there's no guarantee that will work, as it also depends on how your hosting company has their servers set up.

    If all else fails you will need to contact your hosting company and ask them for their help. They'll either be able ot help you, or you'll know that you should start looking for a better place to host your site.

  8. sciofrel
    Member
    Posted 4 months ago #

    Thanks for that tip. It said 256M. I've been able to get back into dashboard after changing plugin folder name.

Reply

You must log in to post.

About this Topic