WordPress.org

Ready to get started?Download WordPress

Forums

how to install multisite in subdomain, working in subdirectories structure (13 posts)

  1. ahalkab
    Member
    Posted 4 years ago #

    tks if anyone could help, just about to loose the head.
    i just want to create a multi site blog, or a network in wordpress words, the detail is that i need it in my subdomain: news.misite.com, and working with sub-directories sites, i mean news.misite.com/site1, news.misite.com/site2.

    Ive read a lot of stuff about .htaccess, wildcard dns, and everything what i should do, i have a go daddy windows server, i know i know ill never get one of this again, but is what i have now, (is not VTP, so i cant acces the httpd.conf file)

    after installing my multisite i get from wp, a message that a have to:
    1.create the blogs.dir

    2.update my wp-config file:
    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/laesfera/';
    define( 'DOMAIN_CURRENT_SITE', 'laesfera.ret.org.mx' );
    define( 'PATH_CURRENT_SITE', '/laesfera/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    3.then to update the web.config file:
    <?xml version="1.0" encoding="UTF-8"?>
    <configuration>
    <system.webServer>
    <rewrite>
    <rules>
    <rule name="WordPress Rule 1" stopProcessing="true">
    <match url="^index\.php$" ignoreCase="false" />
    <action type="None" />
    </rule>
    <rule name="WordPress Rule 2" stopProcessing="true">
    <match url="^([_0-9a-zA-Z-]+/)?files/(.+)" ignoreCase="false" />
    <action type="Rewrite" url="wp-includes/ms-files.php?file={R:2}" appendQueryString="false" />
    </rule>
    <rule name="WordPress Rule 3" stopProcessing="true">
    <match url="^([_0-9a-zA-Z-]+/)?wp-admin$" ignoreCase="false" />
    <action type="Redirect" url="{R:1}wp-admin/" redirectType="Permanent" />
    </rule>
    <rule name="WordPress Rule 4" stopProcessing="true">
    <match url="^" ignoreCase="false" />
    <conditions logicalGrouping="MatchAny">
    <add input="{REQUEST_FILENAME}" matchType="IsFile" ignoreCase="false" />
    <add input="{REQUEST_FILENAME}" matchType="IsDirectory" ignoreCase="false" />
    </conditions>
    <action type="None" />
    </rule>
    <rule name="WordPress Rule 5" stopProcessing="true">
    <match url="^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*)" ignoreCase="false" />
    <action type="Rewrite" url="{R:2}" />
    </rule>
    <rule name="WordPress Rule 6" stopProcessing="true">
    <match url="^([_0-9a-zA-Z-]+/)?(.*\.php)$" ignoreCase="false" />
    <action type="Rewrite" url="{R:2}" />
    </rule>
    <rule name="WordPress Rule 7" stopProcessing="true">
    <match url="." ignoreCase="false" />
    <action type="Rewrite" url="index.php" />
    </rule>
    </rules>
    </rewrite>
    </system.webServer>
    </configuration>

    i couldt find this file, so i create it.

    it was supposed to work after doing this changes, but since then, i ve just get a 500 - Internal server error.

    ive tried creating a .htaccess file:
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ - [L]

    # uploaded files
    RewriteRule ^([_0-9a-zA-Z-]+/)?files/(.+) wp-includes/ms-files.php?file=$2 [L]

    # add a trailing slash to /wp-admin
    RewriteRule ^([_0-9a-zA-Z-]+/)?wp-admin$ $1wp-admin/ [R=301,L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ - [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(wp-(content|admin|includes).*) $2 [L]
    RewriteRule ^([_0-9a-zA-Z-]+/)?(.*\.php)$ $2 [L]
    RewriteRule . index.php [L]

    but, nothing, just the same message, , ive try with many things, but i just get the same message, i would like to know if its possible to do what im looking for, or just quit wasting my time, tks

  2. alm06130
    Member
    Posted 4 years ago #

    I don't understand all of the message, the web config is unknown from me, but :
    if your sites are to be news.misite.com (main site), news.misite.com/site2, news.misite.com/site3 aso, I think you have to set:

    define( 'MULTISITE', true );
    define( 'SUBDOMAIN_INSTALL', false );
    $base = '/';
    define( 'DOMAIN_CURRENT_SITE', 'news.misite.com' );
    define( 'PATH_CURRENT_SITE', '/' );
    define( 'SITE_ID_CURRENT_SITE', 1 );
    define( 'BLOG_ID_CURRENT_SITE', 1 );

    I have two multisites working like this.

  3. ahalkab
    Member
    Posted 4 years ago #

    no alm, i try but i get just the same message, do u have r sites working on godaddy? if yes can u send me a copy of the code of the web.config file or the .htaccess file tks

  4. @alm06130 their web.config is for Windows servers, that's why it looks different.

    @ahalkab see http://www.lauragentry.com/wordpress/?p=517

  5. ahalkab
    Member
    Posted 4 years ago #

    tks andrea, i've reinstall my site in another sub-domain with the main instructions u gave me, but now the problem is that i cant login, i see the screen to place my username and pass but it doesnt allow me to get in.
    i rode the info about the iss, tks i know much more now, ive been trying a few tricks but i still cant access to my dashboard, the problem is that im not sure about know what should i change to fix my problem.
    (im redirected to the login page after trying to log in, but getting a message of wrong pass or user when i typed wrong; i get a 500 error server again, just when try to send the password to my mail, or when try to send a comment from the blog, that looks good in a first impression)

    i figured that the problem may be relationated with the adress i get after trying to log in:
    http://news.misite.org.ps/wp-login.php?redirect_to=http%3A%2F%2Fnews.misite.org.ps%2Fwp-admin%2F&reauth=1

    i was thinking about rewriting that adress (italic) with a
    http://news.misite.org.ps/wp-admin/&reauth=1
    but not sure if that will solve the problem

    tks if anyone could help

  6. Did you clear your browser cache & cookies?

  7. gazouteast
    Member
    Posted 4 years ago #

    @ ahalkad

    Cannot be 100% sure, but I think you have what's called in WordPress file naming convention " forget_the_old_login_dangit " problems.

    In your browser tools or options menu, find the remembered username and password list and clear (delete) the saved entry for the original site build, then try logging in again - not sure if it's the browser or WordPress but ...

    if your old login was "Myusername" and it's saved in the browser list, even if you rebuild the site and use a new login "myusername", either the browser or WordPress rewrites it back to capital M after you hit the enter, and it'll cycle back to telling you the login is incorrect.

    It's not a cache and cookies issue - it's a saved username and password issue in the browser security/privacy data.

  8. ahalkab
    Member
    Posted 4 years ago #

    tks gazou and andrea fot the attempt, i try but i still couldnt log in, ive try again with a new subdomain and wp 3.01 and i got only that awful 500 - internal server error again, i guess might be something wrong with go daddy servers, any other suggestion???

  9. ahalkab
    Member
    Posted 4 years ago #

    ok ok i ve reading more and i think i know what is the problem.

    Ive already get my dedicated ip adress and add the A Host:* pointing to my ip, that is something that is needed in godaddy servers for multisites in subdomains since mu.

    Ive done this procces in a new subdomain, but now, i cant even reach the login page.

    I think the problem might be that my domain is not the main domain of my account, i mean i have an unlimited plan with go daddy and that allow me to have many domains and an unlimited server, but i have one primary domain who might be the problem. The main domain is example.com but i have to bought with another domain provider a .ps site that godaddy doesnt have, so my domain is myweb.com.ps and it is hosted in my hosting unlimited plan in the account of example.com

    So, the network im trying to install is in: news.myweb.com.ps and i think i should redirect this somehow, i think the server might be calling example.com because this is my main domain, does anyone knows if this is really the problem and if this have an unexpensive solution??

  10. @ahalkab - before you go trying a whole bunch of other things, find another browser and login from there.

    It's not a cache and cookies issue - it's a saved username and password issue in the browser security/privacy data.

    ... which is stored in the cache & with cookies... So, same thing.

  11. ahalkab
    Member
    Posted 4 years ago #

    yes andrea, actually i almost clean evrything and nothing. Ive add the subdomain as a A record in total dns control zone to redirect this subdomain to the dedicated ip adress of my server, but nothing. i tried again, and just get the same error 500...

  12. Is this before you even get anything installed?

  13. ahalkab
    Member
    Posted 4 years ago #

    yes, before installing, and the i tried after when i had the chance to view the login page, but now i cant even see that after installing the network...

Topic Closed

This topic has been closed to new replies.

About this Topic