WordPress.org

Ready to get started?Download WordPress

Forums

How to increase or adjust memory size for a hosting ? (5 posts)

  1. rachida
    Member
    Posted 1 year ago #

    I'm not eable to get in the admin erea of my website. This is the message I have :

    Fatal error: Allowed memory size of 33554432 bytes exhausted (tried to allocate 6144 bytes) in D:\Hosting\7932336\html\jaimeladifference\wp-admin\includes\deprecated.php on line 833

    http://www.jaimeladifference.com is my website.

    Is memory size trouble coming from wordpress or hosting provider site ? how to solve it ? i'm a novice trying to learn. Please give me as much detail as you can.

    Thanks for your help.

    Rachida

  2. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    You will first need to ask your host what they have set this to in the server environment for your hosting account, then, if possible (allowed), add a php.ini file that includes:

    memory_limit = ###M

    ### is a whole number such as a 32, 64, 128, 256

    Additionally, you may be able to use the wp-config.php file (add this also if using method above and make them match the ###M amount)

  3. rachida
    Member
    Posted 1 year ago #

    Thank you Seacoast. Your answer helped a lot. With the help of my host, I went this morning from windows envoremnent to linux. It seems wordpress is not efficient under windows.

    the migration takes time. I'll be then able to know the momory size of duluxe linux 2 and increase it. I'll keep you posted.

    do you have an idea of momory limit that comes with linux2 ?

  4. Pioneer Valley Web Design
    Member
    Posted 1 year ago #

    This, again, will be host specific, they should be able to advise you on that.

  5. mrtemple
    Member
    Posted 1 year ago #

    I finally think I've solved the White Screen of Death from PHP out of memory Fatal Errors.

    Full details here: http://www.isthisyourhomework.com/how-to-fix-the-wordpress-white-screen-of-death/

    If setting the WordPress and PHP memory limits doesn't work for you, try adding/edditing the following line in either your Apache conf files. I didn't have access to those, so I added the following line to the.htaccess file in my WP server's document root:

    RLimitMEM max

    Many hosts have set limits on each user on shared-use servers. The above setting will unfetter your server and banish the WSOD.

Topic Closed

This topic has been closed to new replies.

About this Topic