WordPress.org

Ready to get started?Download WordPress

Forums

Open in New Window Plugin
[resolved] how to ignore one page (8 posts)

  1. clickmac
    Member
    Posted 1 year ago #

    how to set the plugin to work everywhere else , except one page?

    http://wordpress.org/extend/plugins/open-in-new-window-plugin/

  2. kpgraham
    Member
    Plugin Author

    Posted 1 year ago #

    I am working on a change to the plugin. So that you can put a short code on the page to disable the plugin.

    If you put on the page:

    <script>function kpg_oinw_action(event) {return false;}</script>

    it should cause a javascript error that will kill the function, I think.

    Keith

  3. clickmac
    Member
    Posted 1 year ago #

    when i click on the link, it still opens in a new window....

    i would like for that specific link when clicked, it would not open in a new window.....

  4. kpgraham
    Member
    Plugin Author

    Posted 1 year ago #

    For a specific link, the code would be

    <a target="_self" href=....

    The target="_self" will cause the link to open in the same window. If the plugin sees something already in target it does not open it in a new window.

    just add target="_self" to the A tag.

    Keith

  5. clickmac
    Member
    Posted 1 year ago #

    oh. well how my links are, they are in a category. i don't manually create links.

    for example clicking on menu option on my website directs me to that specific page.

    another example is going to google.com and clicking on the menu option "Images" . would like for it to open in same window, and i do not write the backend of the code for that specific link, wordpress does that for me.

    unless i have to edit the wordpress css to get to that A tag?

    isn't their a code i could type into the custom css of my theme?

  6. clickmac
    Member
    Posted 1 year ago #

    this is a site = http://trottyzone.com

    so when i click on "Forum" i would like for it not to open in new window.

  7. kpgraham
    Member
    Plugin Author

    Posted 1 year ago #

    Every other link shows http://www.trottyzone.com. The forum shows just trottyzone.com.

    Change the forum link and add the www. and you should be home free.

    Keith

  8. clickmac
    Member
    Posted 1 year ago #

    thanks that worked! :)

    and your plugin is awesome :D

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic

Tags

No tags yet.