WordPress.org

Ready to get started?Download WordPress

Forums

Pinboard
How to hide date and author (23 posts)

  1. nims
    Member
    Posted 1 year ago #

    In Pinboard theme, I do not want to show date and author on my home page or single pages. How to remove date and author ?

  2. blazingmoonorg
    Member
    Posted 1 year ago #

    One simple way to do this (without having to create a child theme) is to hide these values by adding custom CSS. You can add the CSS at Appearance > Theme Options > Layout > Custom CSS.

    The date/author meta information for individual posts has a class of "entry-meta", so this CSS will hide it:

    .entry-meta { display: none; }

    As I'm using pinboard, the meta information doesn't appear on the home page, so I can't give you specific CSS for that. But if you view the page source you should find a class being applied to the meta information on the home page. You could try suppressing it in a similar way.

    .[class name goes here] { display: none; }

    This could have unintended consequences of hiding information on other pages, so as with any custom CSS be sure to test it thoroughly.

    Best of luck.

    Andy

  3. nims
    Member
    Posted 1 year ago #

    Thanks I added following

    .entry-author-link { display: none; }
    .entry-permalink { display: none; }
    .entry-date { display: none; }
  4. nims
    Member
    Posted 1 year ago #

    I am talking about Pinboard only.
    The above code could hide author link, date and permalink on home page only not on single page.
    Any suggestions ?

  5. blazingmoonorg
    Member
    Posted 1 year ago #

    If your CSS hides the meta information on the home page, then to hide the meta information on a page that shows an individual post you should just need to add the CSS that I listed above.

    Your final CSS would be:

    .entry-author-link { display: none; }
    .entry-permalink { display: none; }
    .entry-date { display: none; }
    .entry-meta { display: none; }
  6. Mohd Rafie
    Member
    Posted 1 year ago #

    Or the smarter way to follow the standard CSS guide provided by WordPress

    .entry-author-link,
    .entry-permalink,
    .entry-date,
    .entry-meta {
    	display: none;
    }
  7. blazingmoonorg
    Member
    Posted 1 year ago #

    Good point, thanks. I should have thought for a minute before just appending my code to nims' code. :-)

  8. nims
    Member
    Posted 1 year ago #

    why doesn't it hide on single page ?
    Check this http://www.topindianmodels.com/top-fashion-photographers-in-india/

  9. Mohd Rafie
    Member
    Posted 1 year ago #

    I didn't see this code being added on style.css

    .entry-author-link,
    .entry-permalink,
    .entry-date,
    .entry-meta {
    display: none;
    }

    Can you please do that as it should actually hide the .entry-meta on the home page as well.

  10. Akela
    Member
    Posted 1 year ago #

    This is the code that worked for me on Pinboard (removes author name):

    body .entry-meta .entry-author-link {
    display: none;
    }

  11. hartmutnz
    Member
    Posted 1 year ago #

    BIG THANKS. I wanted to do the same thing. So I pasted the whole pinboard "style.css" to the "custom css field in pinboard theme options. (under Layout) Then I pasted
    .entry-author-link,
    .entry-permalink,
    .entry-date,
    .entry-meta {
    display: none;
    }

    into the bottom of the style.css
    Now the home page and post pages don't show the meta info and the site looks more like a website, not a blog site, which I wanted. Thanks again! Groggo

  12. sir_arles
    Member
    Posted 1 year ago #

    Thanks a lot!
    This was really helpful!

  13. mench
    Member
    Posted 1 year ago #

    Mohd Rafie thank you very much.
    work perfect.

  14. jframst
    Member
    Posted 1 year ago #

    How I did it (the dummy's version!) was to go to "Appearance" then "Theme Options", scroll down, and at the bottom uncheck "Show theme credit link", "Show author credit link" and "Show WordPress credit link".

  15. sprodigy
    Member
    Posted 1 year ago #

    Not to hijack the thread, but in the spirit of using the "entry-meta" section, can someone tell me how I can add a "comment" link to the bottom of the post? I see how to remove elements, how about adding? I do not see a thread on this currently.

  16. cluelessmeg
    Member
    Posted 1 year ago #

    You people are amazing. Thank you for responding to these cries for help!

    This thread helped me a lot.

  17. Bunny Sinclair
    Member
    Posted 1 year ago #

    Another solution is to change the date and time settings in General Settings page of your WordPress dashboard to Custom and then delete the format in the text boxes so they are blank.

  18. saki
    Member
    Posted 10 months ago #

    Thank.
    This was really helpful!

  19. The Cynical Monk
    Member
    Posted 9 months ago #

    I copied and pasted that code into "edit CSS" (am using Twenty Eleven) and it has removed the date and author on posts, but at the top of each post it still says "Posted on". How can I get rid of this?

    Cheers!

    http://www.planetfrondar.com

  20. hartmutnz
    Member
    Posted 9 months ago #

    Hi did you try this code:

    .entry-author-link,
    .entry-permalink,
    .entry-date,
    .entry-meta {
    display: none;
    }

    into the bottom of the style.css

    See if that works.

  21. WPyogi
    Volunteer Moderator
    Posted 9 months ago #

    @thecynicalmonk - CSS is theme-specific, so you cannot use Pinboard CSS on a twentyeleven site - please also start your own thread rather than posting in outdated ones.

    @hartmutnz - please do not advise people to modify theme files - changes should be made in Custom CSS or a child theme.

  22. WPyogi
    Volunteer Moderator
    Posted 9 months ago #

    @thecynicalmonk - for help with twentyeleven, please start a new thread here:

    http://wordpress.org/support/theme/twentyeleven#postform

  23. Akela
    Member
    Posted 9 months ago #

    As far as the latest version of Pinboard goes, the following css worked for me, removing just the date and author and keeping Edit and Category links intact:

    .entry-author-link, .entry-date {
    visibility: hidden;
    }

    "display: none" wouldn't do it for some reason.

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags

No tags yet.