WordPress.org

Ready to get started?Download WordPress

Forums

How To Hide Site Name and Maintain SEO (18 posts)

  1. michiko220
    Member
    Posted 2 years ago #

    I'm using Twenty Ten 1.2 and would like to name my site without having the site name showing on my pages. I don't want to delete the site title from the general settings because I want my site to be found when searched for. I've researched this topic, but I couldn't find any of the same code the other sites were telling me to find. Is it theme specific? Please help :)

  2. sylvain.d
    Member
    Posted 2 years ago #

    I'm not really knowledgeable on the SEO but I think indenting it would be the way to go.

    Set the div containing the site title to indent -9999px in your css

  3. michiko220
    Member
    Posted 2 years ago #

    Thank you for getting back to me! Ok, so I do not understand what you have just told me. I am a photographer learning WordPress on my own time. I am good at following directions- can you briefly tell me the steps to do so? I greatly appreciate it- thank you!

  4. sylvain.d
    Member
    Posted 2 years ago #

    can you provide a link to your site. I'll tell you what code to change It's been a while since I read SEO stuff but what i'm suggesting is basicly moving the tile far to the right so it won't show for a normal user but can still be crawled by bots.

  5. bsmcgillis
    Member
    Posted 2 years ago #

    You don't want to use CSS to hide a <div>. It's considered cloaking (or something like that) and can harm your search engine ranking.

    A better idea would be to replace your site name with an image and then put your company's name in the alt tag for the image.

    Here's a tutorial on how to do it:
    http://www.blog.web6.org/add-logo-to-twenty-ten-wordpress/

  6. michiko220
    Member
    Posted 2 years ago #

    adrianecalaway.com

    Thanks, let me know what you think.

  7. sylvain.d
    Member
    Posted 2 years ago #

    try adding this to your style.css file

    #site-title {
    indent: -9999px;
    }

    if it's not working put the title back and i'll look some more

  8. michiko220
    Member
    Posted 2 years ago #

    Does it matter where I add that in my style.css?

  9. sylvain.d
    Member
    Posted 2 years ago #

    it can but without having an actual title to inspect I can't really be more precise. Try putting it at the end and if it's not working enter a title in your setting and i'll be able to tell you what css rule to change.

  10. michiko220
    Member
    Posted 2 years ago #

    Ok, so I put that line of code at the end of my style.css, but it added a site name footer instead. I erased the added line, but the footer remained. Anyway, I've left the site name on so you can see what it's doing. Thank you so much! This will help me out greatly.

  11. sylvain.d
    Member
    Posted 2 years ago #

    hmmm it's been a long night... what i gave you wasn't a real property. The correct name is text-indent.

    So now if i gave you the right code it should work hehe

    in your style.css file change line 341

    from

    #site-title {
    float: left;
    font-size: 30px;
    line-height: 36px;
    margin: 0 0 18px 0;
    width: 700px;
    }

    to

    #site-title {
    float: left;
    font-size: 30px;
    line-height: 36px;
    margin: 0 0 18px 0;
    width: 700px;
    text-indent: -9999px;
    }

    and change line 189
    from

    #site-info {
    float: left;
    font-size: 14px;
    font-weight: bold;
    width: 700px;
    }

    to

    #site-info {
    float: left;
    font-size: 14px;
    font-weight: bold;
    width: 700px;
    text-indent: -9999px;
    }

    PS: Going to sleep. I'll check back tomorow and see if this solved it.

  12. michiko220
    Member
    Posted 2 years ago #

    Ok, so I did exactly what you suggested, but unfortunately it didn't change anything. Let me know what else you can come up with whenever you get a chance. Thanks!

  13. sylvain.d
    Member
    Posted 2 years ago #

    weird. it was working for me. Can you put the title back. I'll try and see what I missed.

  14. michiko220
    Member
    Posted 2 years ago #

    Ok I put the title back for you!

  15. sylvain.d
    Member
    Posted 2 years ago #

    It's still working on my side. Sorry to insist on my previous answer but could you recheck by copy/pasting my codes over your old ones. That way I would be certain it's not a typo or something that breaking it on your side.

    Thanks

  16. michiko220
    Member
    Posted 2 years ago #

    I triple checked just now and unfortunately it still doesn't change anything. Any other suggestions?

  17. sylvain.d
    Member
    Posted 2 years ago #

    Sorry i'm all out of idea on why it's not working for you. I jus saw bsmcgillis' reply maybe it's a better way to achieve this.

  18. michiko220
    Member
    Posted 2 years ago #

    Thank you for your help. I really appreciate it! Seems like that should have done something...

Topic Closed

This topic has been closed to new replies.

About this Topic