WordPress.org

Ready to get started?Download WordPress

Forums

raindrops
[resolved] How to have fluid function with custom width? (10 posts)

  1. Martss
    Member
    Posted 1 year ago #

    Hello!

    Is it somehow possible to change page width so that it's width has an maximum value (for example 750px), but when smaller than that, then fluid?

    I would like to have an narrow page, but when using on mobile device for example, then this fluid feature is really great!

  2. Andrew
    Forum Moderator
    Posted 1 year ago #

    Sounds like you want the max-width CSS property
    http://www.w3schools.com/cssref/pr_dim_max-width.asp

  3. Martss
    Member
    Posted 1 year ago #

    Thank you very much for your answer. I looked in style.css file, but there was only possible to set this max-width in precentages, is it somehow also possible in pixels?

    Just like in the "Raindrops options", but there is possible only 4 options:
    1)750px centerd
    2)950px centerd
    3)fluid
    4)974px.

    I would like to set fluid option, with custom maximum width.

  4. Andrew
    Forum Moderator
    Posted 1 year ago #

    Wow, that sounds like a great theme if it gives you those options you said.

    Can you use the Fluid option and then link to your website?

  5. Martss
    Member
    Posted 1 year ago #

    Yes, you are right, it is really great theme! I am using at the moment 750px centred option, but I can put it for about a hour to fluid mode :)

    You can feel free to click http://www.saksavalgus.ee

    My ideal would be something like 750-800px maximum width with fluid option enabled.

  6. Andrew
    Forum Moderator
    Posted 1 year ago #

    If there is no other option in the dashboard for this, you ought to create new styles externally; as not to edit the theme's files.

    External styles can be added through the dashboard by using a Custom CSS Manager plugin. Then, in that Custom CSS Manager section of the dashboard, try entering this;

    #doc3 {
     max-width: 750px;
    }

    Is that what you want?

  7. Martss
    Member
    Posted 1 year ago #

    Thank you very much. I tried with this Custom CSS manager and added these lines.

    Unfortunately it changes nothing. If I put from "Raindrops options" fluid mode. Then maximum width is not 750 px :(

  8. nobita
    Member
    Theme Author

    Posted 1 year ago #

    Hi Martss

    Please open functions.php

    and add below code first line.

    /**
     * fluid page  minimum width px
     */
            $raindrops_fluid_minimum_width = '320';
    /**
     * fluid page  maximum width px
     */
            $raindrops_fluid_maximum_width = '1280';

    and when you need cutom width page try below
    $raindrops_page_width = '';
    set your pixel value.

    Thank you

  9. nobita
    Member
    Theme Author

    Posted 1 year ago #

    Add info

    Change of a $raindrops_fluid_maximum_width may affect a style.

    if page not centered.

    modify style.css.

    change below from 1280px to your $raindrops_fluid_maximum_width.

    @media screen and (min-width : 1280px){
    	#doc3{
    		margin:0 auto;
    	}
    }

    Thank you.

  10. Martss
    Member
    Posted 1 year ago #

    Hello nobita,

    Thank you very much, the problem is now resolved. It works really great!

Topic Closed

This topic has been closed to new replies.

About this Theme

About this Topic

Tags