WordPress.org

Ready to get started?Download WordPress

Forums

[closed] How to get rid of unwanted link on homepage (27 posts)

  1. cbaz
    Member
    Posted 12 months ago #

    Hi,

    I posted the other day about this problem, but still haven't been able to figure it out. I have a link that appears at the top of my homepage-- 'Happy Wheels Webeden'--that I can't seem to get rid of. I have no idea how it got there. I deactivated each of my plugins, one by one, to see if one of them was the culprit. No luck. I've searched in some of php files for the link also. Any other ideas on how to get rid of this link?

    My page: http://thenaturallyhealthyhorse.com

    Thank you.

  2. Evan Herman
    Member
    Posted 12 months ago #

    Check your header.php file.

    It looks like the theme author has placed that there for advertising purposes.

    If you let us know what theme you are using, I can better assist.

    My best guess is header.php or functions.php

  3. cbaz
    Member
    Posted 12 months ago #

    It's the twenty eleven theme. I'll check the header and functions.php again.

  4. Evan Herman
    Member
    Posted 12 months ago #

    It's the twenty eleven theme? There should be no link at the top of the page, unless you have set it there.

    As you know, twenty eleven doesn't come default with that.

  5. Evan Herman
    Member
    Posted 12 months ago #

    Also, what plugins do you have installed?

  6. cbaz
    Member
    Posted 12 months ago #

    Yes, it appeared a few months ago.

  7. lettergrade
    Member
    Posted 12 months ago #

    It's definitely in the header (so, I assume header.php), and it's before the </head> tag ends so it is almost surely there accidentally ;)

    When you find it, you should remove the whole line, starting and ending with the <p> and </p> tags.

  8. Evan Herman
    Member
    Posted 12 months ago #

    If it's not in the header.php or functions.php, I'd say your site was hacked.

    That shouldn't just appear on the WordPress default theme

  9. cbaz
    Member
    Posted 11 months ago #

  10. cbaz
    Member
    Posted 11 months ago #

    Still can't find it in header.php. . .

  11. Evan Herman
    Member
    Posted 11 months ago #

    remove - G translate and all of its options from the WP database.

    That is the offender. I stumbled across a thread somewhere with this issue, and it was that plugin that was causing them problems.

  12. Evan Herman
    Member
    Posted 11 months ago #

    http://wordpress.org/support/topic/random-casino-link-has-appeared-on-my-wordpress-site?replies=20

    Look at 'anotherfinemess' post about half way down the page - direct quote here

    Ok guys it was a plugin afterall that caused these spam links. It's the G Translate plugin from benjilof . Delete it and you'll be fine. It activated the spam links in all my wordpress sites. Please confirm this. Thanks

  13. lettergrade
    Member
    Posted 11 months ago #

    Good to know, Evan.

  14. cbaz
    Member
    Posted 11 months ago #

    I deleted G Translate, but the link is still there!

  15. cbaz
    Member
    Posted 11 months ago #

    When you say 'remove all its options from the WP database', what does that mean exactly?

  16. Evan Herman
    Member
    Posted 11 months ago #

    Well, when a plugin is installed it must register settings inside of the database, so it knows where to store the information. Most plugin authors do not code in an uninstall, which removes these options from the database. So even tho you have 'removed' the plugin from the list of installed plugins, the options/settings may still be inside of the database.

    I'm no pro at digging through the database, so hopefully someone else can guide you through that.

    I believe essentially what you would need to do is - log in to phpMyAdmin, select the database wordpress is installed too, select the options table (again, I *think*), and find and select the settings for that plugin and 'Drop' them from the database.

    Maybe wait for another to chime in for support, so you don't crash your site permanently (which could very well happen messing around in the database).

  17. Evan Herman
    Member
    Posted 11 months ago #

    this could be of some help too - it's mentioned here again

    http://wordpress.org/support/topic/site-hacked-nemonn-tag-infected-with-scam-description?replies=23

    Let us know if you get this resolved, as I would like to know the offending plugin/issue for future problem-solving/support.

  18. cbaz
    Member
    Posted 11 months ago #

    I know just enough to get by in wordpress--definitely don't want to crash my site. I'll just live with the link if I have to for now!

  19. Evan Herman
    Member
    Posted 11 months ago #

    Hey,
    what ever you did it looks like the link has vanished. Did you remove that plugin (g-translate)?

  20. cbaz
    Member
    Posted 11 months ago #

    It actually comes and goes sometimes. I have no idea why. It disappeared for a while the other day so I thought I'd figured out the problem. I'll keep an eye on it and see if it returns. If not, maybe the G-translate plugin was it after all. . . Thank you for your help.

  21. cbaz
    Member
    Posted 11 months ago #

    The link is still gone, so I'm keeping my fingers crossed that the G-translate plugin was the culprit after all.

  22. cbaz
    Member
    Posted 11 months ago #

    Ok, I have a totally separate problem now, but when I keep trying to post it to ask for help, it gets deleted. So I'll post it here--I'm desperate!

    When I added a banner to my site a few weeks ago, some text on several pages somehow got linked along with the banner. I need to unlink the text. It's probably related to how I put the banner in the header.php, but I can't figure out what to do.

    Here's my site again: http://thenaturallyhealthyhorse.com

    Here's an example page that has linked text: Advertise

    Thanks in advance if anyone can help!

  23. cbaz
    Member
    Posted 11 months ago #

    btw--the original problem in this post was resolved. It was the google translate plug-in. Thanks Evan Herman!

  24. WPyogi
    Volunteer Moderator
    Posted 11 months ago #

    I'm sorry if this is a different issue and your thread was wrongly closed, but you have a major problem in that you've modified twentyeleven theme - which means that all of your changes will be lost when WP is updated. You should be using a Child Theme -

    http://codex.wordpress.org/Child_Themes

    You've also created quite a few mark-up errors - starting with putting code above the DOCTYPE in the header.php - there should NEVER be any code there -

    http://validator.w3.org/check?uri=http%3A%2F%2Fthenaturallyhealthyhorse.com%2F&charset=%28detect+automatically%29&doctype=Inline&group=0

    On the Advertise page, see:
    http://validator.w3.org/check?uri=http%3A%2F%2Fthenaturallyhealthyhorse.com%2Fadvertise%2F&charset=%28detect+automatically%29&doctype=Inline&group=0

  25. cbaz
    Member
    Posted 11 months ago #

    I know I messed up by modifying code in my theme. I would actually like to hire someone to help me fix several problems and make a child theme--but I haven't had any luck finding someone yet. I'm a writer--not a web developer!!! I will check into the links you provided. Thank you.

  26. lettergrade
    Member
    Posted 11 months ago #

    cbaz, you can try looking for someone here: http://jobs.wordpress.net/

  27. esmi
    Forum Moderator
    Posted 11 months ago #

    This topic has now been closed as per the Forum Rules

Topic Closed

This topic has been closed to new replies.

About this Topic