WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] How to get rid of "read more" (5 posts)

  1. nicolex
    Member
    Posted 4 years ago #

    I would like the main page of my blog to not have the "read more" option. I would like my entire post to show up automatically. How can I delete this function?

    I tried changing the post size from 10 lines to 100 lines and yet I'm still only getting about 2 lines of text and then the "read more" link.

    Where and how do I fix this?

  2. That should only happen if you're actually inserting a "More" tag into your post. However, it is possible that your theme is only displaying excerpts. Could you provide a link to your blog so we can investigate?

  3. Karine
    Member
    Posted 4 years ago #

    Are you using the_excerpt(); in your theme index.php ? If yes, change it to the_content();

  4. nicolex
    Member
    Posted 4 years ago #

    Thanks Ka-ri-ne that worked!

  5. lpaulsen
    Member
    Posted 4 years ago #

    I am having this same problem. I don't know much about code, but I changed to "content" instead of excerpt in the main index

    <p><?php ob_start(); the_content(); echo dp_clean_excerpt(ob_get_clean()); ?> ">Read More</p>

    But I tried to change the dp_clean_excerpt and it looks terrible when I change that to content.

    What I want is for my whole post to show, including pictures. No read more option, either! Pelase help.

Topic Closed

This topic has been closed to new replies.

About this Topic