WordPress.org

Ready to get started?Download WordPress

Forums

how to get rid of "leave a reply"? (14 posts)

  1. Dargon12
    Member
    Posted 1 year ago #

    hey people:)
    i'm new to wordpress and i got a problem,
    i can't get rid of the "leave a replay" box,
    in the end i want to make it apear in only one page and not to leave a comment on the site but to sent the comment to my mail.
    is it possible?
    and i'm using the "magazine-basic" theme :)
    and here is my site

  2. LapanSite
    Member
    Posted 1 year ago #

    Link?

  3. Dargon12
    Member
    Posted 1 year ago #

    edited my post

  4. LapanSite
    Member
    Posted 1 year ago #

    #respond {
    display: none;
    }

    Fastest way.

  5. Dargon12
    Member
    Posted 1 year ago #

    ok.. but in what file do i write it?

  6. LapanSite
    Member
    Posted 1 year ago #

    Or, you can disable comments on specific posts, pages.
    This, up, will hide it everywhere.

  7. LapanSite
    Member
    Posted 1 year ago #

    wp-content/themes/magazine-basic/style.css

    for that

    #respond {
    display: none;
    }
  8. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    You should not be modifying theme files - instead add to custom CSS - if your theme does not have Custom CSS, add it via a plugin like Custom CSS Manager.

  9. Dargon12
    Member
    Posted 1 year ago #

    ok first think is done and thank you for it.
    now the second part : how to make it apear only on one page?
    and make it leave a comment right to my mail?

  10. LapanSite
    Member
    Posted 1 year ago #

    You do not need a plugin for that.
    You can create custom.css, and add in theme header, just after <head> tag:

    <link rel="stylesheet" href="<?php bloginfo('stylesheet_url'); ?>/custom.css" type="text/css" media="screen" />

    You could also @import it, but link rel is faster to load.

  11. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    That is not the correct way to add a stylesheet - AND header.php file should not be modified either.

    See: Adding stylesheets -
    http://codex.wordpress.org/Function_Reference/wp_enqueue_style

    Modifying theme files should be done in a Child Theme -

    http://codex.wordpress.org/Child_Themes

  12. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    @Dargon12 - going back to your original question, did you turn off comments on that page?

    Go to the pages screen and click on Quick Edit for that page - then uncheck "Allow Comments"

  13. Dargon12
    Member
    Posted 1 year ago #

    WPyogi i have done it and the option to comment is now off now i want to allow it only in one page to sent comments to my mail directly

  14. WPyogi
    Volunteer Moderator
    Posted 1 year ago #

    Which page?

    See this re: comments:

    http://codex.wordpress.org/Comments_in_WordPress

Topic Closed

This topic has been closed to new replies.

About this Topic