WordPress.org

Ready to get started?Download WordPress

Forums

[resolved] How to force www in htaccess with permalinks?? (4 posts)

  1. markm455
    Member
    Posted 6 years ago #

    Hi. I have a wordpress blog installed at example.com/blog and also have permalinks setup. So the directory folder blog on my server has the htaccess entry below.
    -------------------------
    <IfModule mod_rewrite.c>
    RewriteEngine On
    RewriteBase /blog/
    RewriteCond %{REQUEST_FILENAME} !-f
    RewriteCond %{REQUEST_FILENAME} !-d
    RewriteRule . /blog/index.php [L]
    </IfModule>
    ---------------------------
    The problem is I cant get the force www entry to work with this. I have it working fine in the "public html" folder but not the "blog" folder. I have tried a ton of combinations with no success.

    Anybody have this working? Thanks.

  2. Samuel Wood (Otto)
    Tech Ninja
    Posted 6 years ago #

    Check the two URLs on the Settings->General screen. Do they have www's in them? Have you tried putting www's in them?

  3. markm455
    Member
    Posted 6 years ago #

    That fixed it! I was missing the www in that setting.

    Guess I should have looked through the settings in wordpress better before messing with htaccess.

    Thanks!

  4. matteoraggi
    Blocked
    Posted 5 years ago #

    it is fixed to me, but then if I directly write http://www.luxury-furniture.biz it don't go, why? ;(

Topic Closed

This topic has been closed to new replies.

About this Topic

Tags

No tags yet.