WordPress.org

Ready to get started?Download WordPress

Forums

how to force second TinyMCE toolbar to show (3 posts)

  1. oats
    Member
    Posted 6 years ago #

    I am recently trying to fix one of my plugins to be compatible with version 2.5. It makes some modifications to the TinyMCE toolbar. One of the things it did in previous versions is always make the advanced toolbar visible (the second toolbar row).

    I do not use the 'wp_adv' button, since I always show the two toolbar rows.

    The new version 2.5 seems to do things differently... showing the seconds toolbar seems to be dependent on setting a cookie value, even if the 'wp_adv' button is not present in the toolbar. So my second row is hidden by default, and I have no way to make it show. (Unless I enable the 'wp_adv' button, which I don't want to do.)

    How can I force the second toolbar row to show always?

    Some relevant code from the wordpress TinyMCE plugin:

    if ( tinymce.util.Cookie.get('kitchenSink') == '1' )
    				ed.settings.wordpress_adv_hidden = 0;
    
    			// Hides the specified toolbar and resizes the iframe
    			ed.onPostRender.add(function() {
    				if ( ed.getParam('wordpress_adv_hidden', 1) ) {
    					DOM.hide(ed.controlManager.get(tbId).id);
    					t._resizeIframe(ed, tbId, 28);
    				}
    			});
  2. oats
    Member
    Posted 6 years ago #

    any ideas here? there has definitely been a change in 2.5 that caused this. perhaps i need to focus on how i can set this particular cookie with my plugin?

  3. manchumahara
    Member
    Posted 5 years ago #

    hi, have u any update about how can I add the any custom plugin button in 2nd row in tinymce. As in admin/inlcludes/post.php tinymce loads $teeny mode bydefault and it has only one row for toolbar.

Topic Closed

This topic has been closed to new replies.

About this Topic