WordPress.org

Ready to get started?Download WordPress

Forums

Contact Form
[resolved] How to enable multilingual ? (7 posts)

  1. ____
    Member
    Posted 1 year ago #

    The Contact Form is working perfectly when being used in only the English language.

    However, as soon as I try to use a different language, the field titles disappear. Like this.

    The .mo and .po files are in the languages folder so the translations should be available.

    I activate the form by pasting the shortcode (e.g. [contact_form lang=de]) in the relevant page.

    Can someone please tell me what I am doing wrong.

    http://wordpress.org/extend/plugins/contact-form-plugin/

  2. AlastairA
    Member
    Posted 1 year ago #

    I have this issue too with both French and Italian.

    However, if you select "Display tips below the Attachment block" that text is correctly rendered in the right language!

    Sounds like a path is being created incorrectly (except the above exception) so the mo files are not being found.

    I do have my wordpress directory in a different directory than the site. Maybe this is an issue?

    Could someone with better coding skills and/or knowledge of the code have a look and help Prince09d and me, please?

    Thanks
    Alastair

  3. ____
    Member
    Posted 1 year ago #

    mmm, i can't even enable the tips.

    anyway would be much appreciated if someone could sort this out.

  4. ____
    Member
    Posted 1 year ago #

    Could anyone at least tell me if this plugin is actually tested and confirmed multilingual?

  5. ____
    Member
    Posted 1 year ago #

    Ok just found out that this plugin does not have multilingual support. It will only display the language of your WP installation.

    Please make this clear in the plugin description. It will save a lot of people a lot of time.

  6. AlastairA
    Member
    Posted 1 year ago #

    I have got this plug-in to work with my three language website (under construction). However, I have to manually enter the text for each element under the option "Change the names of the contact form fields and error messages" (plug-in->settings).

    Given the translations have already been done and in the .mo files, it is just cut and paste but annoying. Weirdly, the text for attachement tips correctly translates automatically.

    Seems like a bug to me but at least there is a workaround.

  7. bestwebsoft
    Member
    Plugin Author

    Posted 1 year ago #

    Hello,

    "How to add the contact form not in English?" -
    Add a language in the block "Language settings for the field names in
    the form" on the plugin settings page.
    Mark the check box (if it's not marked yet) in the block "Change the
    names of the contact form fields and error messages", choose the
    necessary tab and fill in the fields. Choose the necessary tab in the
    block "Action after email is sent" as well and fill in the field. Save
    the changes.
    You will see the shortcode under the tab with the necessary language.
    Please paste that shortcode to the page or post.

    Kind regards,
    Support Team

Topic Closed

This topic has been closed to new replies.

About this Plugin

About this Topic