WordPress.org

Ready to get started?Download WordPress

Forums

How to embed swf file that loads content from xml file (8 posts)

  1. Fariba21
    Member
    Posted 4 years ago #

    Hi All,

    I have been trying to embed an xml driven swf file into my WordPress page and it's not showing up

    I have bought an interactive Video/Image Gallery online. The downloaded folder came with main files as all source files. I do have some knowledge of working with Flash but not so much with Actionscript. This Gallery came with an external xml file which I could replace the images and videos and have it played.

    The swf works fine from my computer as well as directly from an html page. Here is the link to where the swf is directly uploaded and works in an html environment (“wp-content/uploads/...” folder)

    I uploaded all of the loading contents as it was instructed by the designer in the same order it was instructed, and to be on the safe side, I uploaded the rest of the files (the whole folder as it sits on my hard drive).

    Then I embedded this swf into my WordPress page using this code:

    <object style="width: 590px; height: 300px;" classid="clsid:d27cdb6e-ae6d-11cf-96b8-444553540000" width="590" height="300" codebase="http://download.macromedia.com/pub/shockwave/cabs/flash/swflash.cab#version=6,0,40,0"><param name="quality" value="high" />
    <param name="scale" value="noscale" />
    <param name="src" value="http://envisionadvertising.com/wp-content/uploads/2009/swfs/vidGal1/bin-debug/Main.swf" />
    <embed style="width: 590px; height: 300px;" type="application/x-shockwave-flash" width="590" height="300" src="http://envisionadvertising.com/wp-content/uploads/2009/swfs/vidGal1/bin-debug/Main.swf" scale="noscale" quality="high"></embed>
    </object>

    And it’s not working in my WordPress page. The swf file loades but not the content. Here is the link to WordPress page with embedded swf...

    The embed code I'm using is the same one I've been using for all my WordPress pages and it always works. The only difference this time is that: this swf is not independent and all images and videos are not embedded within the file, they're pulled up from an attached source folder and there are several Actionscript files that are also included within the folder.

    I have included a quick snapshot of the folder with the instructed files for upload here.
    I have also included a Tree of Folders and Subfolders in a word format here. (which BTW I have uploaded all of these files along with the main files just to be on the safe side

    Is there any difference? What am I doing wrong or what am I missing? PLEASE HELP!

  2. jadoux
    Member
    Posted 4 years ago #

    I have the exact same problem, and i am getting frustrated of trying tons of code lines without any success, simply the SWF loads as if it has no content, while the exact same html code, written in an html file works simply fine, i will be thankful if someone comes up with an idea

  3. radu4iasi
    Member
    Posted 4 years ago #

    Hello
    I am a flash developer, I, too, am trying to embed a swf with contens on my blog. One thing I think you will find usefull is that the external assets of the swf need to be in a path relative to the html that embeds it, not the swf itself ( if tried to run from a html ).

    i will keep you posted in what I found

  4. soamz
    Member
    Posted 4 years ago #

    Hi..
    Im trying the same.
    Can anyone help please ???

  5. Vinicius Massuchetto
    Member
    Posted 4 years ago #

    Hi!

    I was having the same issue. The solution I found:

    1) The path SWF looks for the XML is the page URL, not the folder the SWF file is. So it is needed to give the full XML path to the load function into its action:
    xmlobject.load("http://path/to/the/xml/file.xml")

    2) The same with paths inside the XML. It is needed to always fill references with the full path;

    3) It is recommended to use Kimili Flash Embed Plugin [1], once it will use all the JavaScript needed to load flash files. The syntax is very easy:
    e.g.: [kml_flashembed movie="<?php bloginfo('template_directory'); ?>/swf/file.swf" wmode="transparent" width="300" height="300"]

    Well.. that's it. Hope it helps.
    --
    Vinicius Massuchetto
    http://vinicius.soylocoporti.org.br

    [1] http://kimili.com/plugins/kml_flashembed

  6. MichaelH
    Member
    Posted 4 years ago #

    Connecting the dots--related wp-hackers thread:
    http://lists.automattic.com/pipermail/wp-hackers/2010-March/031062.html

  7. JanjaWat1
    Member
    Posted 3 years ago #

    Hello Vinicius,
    thanks for your explanation for the xml issue. I'm trying the same thing but I'm not sure where to put this code:
    xmlobject.load("http://path/to/the/xml/file.xml")

    The fla file I'm using does not seem to have a actions layer.
    Do I have to add that to the swf file?
    Can I load the flash with this propperty like this?

    <div id="slide">
    <script type="text/javascript">
    swfobject.embedSWF('http://vistawebdesign.info/flash/main.swf',
    xmlobject.load('http://vistawebdesign.info/flash/data.xml'),
    'slide', '700', '550', '9.0.0.0', '', { folderPath: 'http://vistawebdesign.info/wp-content/flash/' }, { scale: 'noscale', wmode: 'transparent', allowScriptAccess: 'always', allowFullScreen: true }, { });
    </script>
    </div>

    Thanks Janja

  8. greenwizard
    Blocked
    Posted 3 years ago #

    so this thing never got solved?

Topic Closed

This topic has been closed to new replies.

About this Topic